# CVE-2025-46558: org.xwiki.contrib.markdown:syntax-markdown-commonmark12 vulnerable to XSS via Markdown content

> Attackers can inject JavaScript via Markdown content, leading to XSS and potential full system compromise if executed by privileged users.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Apr 2025
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-8g2j-rhfh-hq3r

## What is CVE-2025-46558?

CVE-2025-46558 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 30 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Contrib's Syntax Markdown allows importing Markdown content into wiki pages and creating wiki content in Markdown. In versions starting from 8.2 to before 8.9, the Markdown syntax is vulnerable to cross-site scripting (XSS) through HTML. In particular, using Markdown syntax, it's possible for any user to embed Javascript code that will then be executed on the browser of any other user visiting either the document or the comment that contains it. In the instance that this code is executed by a user with admins or programming rights, this issue compromises the confidentiality, integrity and availability of the whole XWiki installation. This issue has been patched in version 8.9.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-46558?

2 open source packages ship an affected version, including org.xwiki.contrib.markdown:syntax-markdown-commonmark12. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.contrib.markdown:syntax-markdown-commonmark12` | Maven | From 8.2 | 8.9 |
| `org.xwiki.contrib.markdown:syntax-markdown-commonmark12` | Maven | From 8.2 | 8.9 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-46558?

Upgrade org.xwiki.contrib.markdown:syntax-markdown-commonmark12 to 8.9 or later.

## Is CVE-2025-46558 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46558 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46558 and fix it if it is affected.

What it is: CVE-2025-46558 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 30 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46558 exists.

Affected packages and fixed versions:
- org.xwiki.contrib.markdown:syntax-markdown-commonmark12 (Maven): affected from 8.2; fixed in 8.9
- org.xwiki.contrib.markdown:syntax-markdown-commonmark12 (Maven): affected from 8.2; fixed in 8.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46558/ (Markdown: https://insights.sbomify.com/CVE-2025-46558/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46558
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46558
- OSV: https://osv.dev/vulnerability/CVE-2025-46558

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46558/
Summaries are generated and may contain mistakes; the official description above is the record.
