# CVE-2025-4656: Vault Vulnerable to Recovery Key Cancellation Denial of Service

> A Vault operator can cause a denial of service by uncontrolled cancellation of rekey or recovery key operations.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jun 2025
- **Updated:** 25 Jun 2025
- **Also known as:** BIT-vault-2025-4656, CLEANSTART-2026-OX83822, GHSA-fhc2-8qx8-6vj7, GO-2025-3788, MINI-7c2c-9m94-8x9j

## What is CVE-2025-4656?

CVE-2025-4656 is a low-severity denial of service vulnerability in Hashicorp Vault, published on 25 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Vault Community and Vault Enterprise rekey and recovery key operations can lead to a denial of service due to uncontrolled cancellation by a Vault operator. This vulnerability (CVE-2025-4656) has been remediated in Vault Community Edition 1.20.0 and Vault Enterprise 1.20.0, 1.19.6, 1.18.11, 1.17.17, and 1.16.22.

Weakness: CWE-1088 (Synchronous Access of Remote Resource without Timeout)

## Which versions are affected by CVE-2025-4656?

4 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault` | Go | From 1.14.8 | 1.20.0 |
| `github.com/hashicorp/vault` | Go | From 1.14.8 | 1.20.0 |
| `github.com/hashicorp/vault` | Go | From 1.14.8 | 1.20.0 |
| `vault` | Bitnami | From 1.14.8 | 1.20.0 |

Products: Hashicorp Vault.

## How do I fix CVE-2025-4656?

Upgrade github.com/hashicorp/vault to 1.20.0 or later.

## Is CVE-2025-4656 being exploited?

There is no known exploitation of CVE-2025-4656 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4656 and fix it if it is affected.

What it is: CVE-2025-4656 is a low-severity denial of service vulnerability in Hashicorp Vault, published on 25 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-4656 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault (Go): affected from 1.14.8; fixed in 1.20.0
- github.com/hashicorp/vault (Go): affected from 1.14.8; fixed in 1.20.0
- github.com/hashicorp/vault (Go): affected from 1.14.8; fixed in 1.20.0
- vault (Bitnami): affected from 1.14.8; fixed in 1.20.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4656/ (Markdown: https://insights.sbomify.com/CVE-2025-4656/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4656
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4656
- OSV: https://osv.dev/vulnerability/CVE-2025-4656

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4656/
Summaries are generated and may contain mistakes; the official description above is the record.
