{"answers":{"affected":"3 open source packages ship an affected version, including vllm. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46560 exists.","fix":"Upgrade vllm to 0.8.5 or later.","what":"CVE-2025-46560 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 30 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-46560 and fix it if it is affected.\n\nWhat it is: CVE-2025-46560 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 30 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46560 exists.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected from 0.8.0; fixed in 0.8.5\n- vllm (PyPI): affected from 0.8.0; fixed in 0.8.5\n- vllm (PyPI): affected from 0.8.0; fixed in 0.8.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-46560/ (Markdown: https://insights.sbomify.com/CVE-2025-46560/index.md)","id":"CVE-2025-46560","markdown":"https://insights.sbomify.com/CVE-2025-46560/index.md","name":"CVE-2025-46560","record":{"aliases":["GHSA-vc6m-hm49-g9qg","PYSEC-2026-2022"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM inference library","requires_auth":"low_privilege","summary":"Attackers can cause denial of service in vLLM by submitting crafted inputs that trigger quadratic time complexity in token processing.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vllm","vendor":"vllm"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.8.0 and prior to 0.8.5 are affected by a critical performance vulnerability in the input preprocessing logic of the multimodal tokenizer. The code dynamically replaces placeholder tokens (e.g., \u003c|audio_|\u003e, \u003c|image_|\u003e) with repeated tokens based on precomputed lengths. Due to ​​inefficient list concatenation operations​​, the algorithm exhibits ​​quadratic time complexity (O(n²))​​, allowing malicious actors to trigger resource exhaustion via specially crafted inputs. This issue has been patched in version 0.8.5.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"vLLM phi4mm: Quadratic Time Complexity in Input Token Processing​ leads to denial of service","id":"CVE-2025-46560","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"vllm:vllm","products":["vllm:vllm"],"type":"denial_of_service","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Vite's server.fs.deny bypassed with /. for files under project root","id":"CVE-2025-46565"},"packages":[{"ecosystem":"PyPI","fixed":["0.8.5"],"introduced":["0.8.0"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-vc6m-hm49-g9qg"},{"ecosystem":"PyPI","fixed":["0.8.5"],"introduced":["0.8.0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-vc6m-hm49-g9qg"},{"ecosystem":"PyPI","fixed":["0.8.5"],"introduced":["0.8.0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"PYSEC-2026-2022"}],"prev":{"headline":"Misskey Directory Traversal Vulnerability in AiScript via `Mk:api`","id":"CVE-2025-46559"},"products":["vllm"],"published":"2025-04-30","related":[{"cvss_score":10,"headline":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration","id":"CVE-2025-32444","kev_date_added":null,"published":"2025-04-30"},{"cvss_score":9.8,"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.8,"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"vLLM: OpenAI auth bypass","id":"CVE-2026-48746","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.1,"headline":"vLLM Allows Remote Code Execution via Mooncake Integration","id":"CVE-2025-29783","kev_date_added":null,"published":"2025-03-19"},{"cvss_score":8.8,"headline":"vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector","id":"CVE-2026-116176","kev_date_added":null,"published":"2026-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-30","vendors":["vllm-project"]},"summary":"Attackers can cause denial of service in vLLM by submitting crafted inputs that trigger quadratic time complexity in token processing.","url":"https://insights.sbomify.com/CVE-2025-46560/"}