# CVE-2025-46560: vLLM phi4mm: Quadratic Time Complexity in Input Token Processing​ leads to denial of service

> Attackers can cause denial of service in vLLM by submitting crafted inputs that trigger quadratic time complexity in token processing.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Apr 2025
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-vc6m-hm49-g9qg, PYSEC-2026-2022

## What is CVE-2025-46560?

CVE-2025-46560 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 30 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.8.0 and prior to 0.8.5 are affected by a critical performance vulnerability in the input preprocessing logic of the multimodal tokenizer. The code dynamically replaces placeholder tokens (e.g., <|audio_|>, <|image_|>) with repeated tokens based on precomputed lengths. Due to ​​inefficient list concatenation operations​​, the algorithm exhibits ​​quadratic time complexity (O(n²))​​, allowing malicious actors to trigger resource exhaustion via specially crafted inputs. This issue has been patched in version 0.8.5.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2025-46560?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.8.0 | 0.8.5 |
| `vllm` | PyPI | From 0.8.0 | 0.8.5 |
| `vllm` | PyPI | From 0.8.0 | 0.8.5 |

Products: Vllm Vllm.

## How do I fix CVE-2025-46560?

Upgrade vllm to 0.8.5 or later.

## Is CVE-2025-46560 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46560 exists.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46560 and fix it if it is affected.

What it is: CVE-2025-46560 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 30 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46560 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.8.0; fixed in 0.8.5
- vllm (PyPI): affected from 0.8.0; fixed in 0.8.5
- vllm (PyPI): affected from 0.8.0; fixed in 0.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46560/ (Markdown: https://insights.sbomify.com/CVE-2025-46560/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46560
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46560
- OSV: https://osv.dev/vulnerability/CVE-2025-46560

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46560/
Summaries are generated and may contain mistakes; the official description above is the record.
