# CVE-2025-46565: Vite's server.fs.deny bypassed with /. for files under project root

> Attackers can bypass file access restrictions to read sensitive files like .env from the project root if the Vite dev server is exposed to the network.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 May 2025
- **Updated:** 2 May 2025
- **Also known as:** CLSA-2026-1792764572, GHSA-859w-5945-r5v3, MINI-29w9-27rf-fchp

## What is CVE-2025-46565?

CVE-2025-46565 is a medium-severity path traversal vulnerability in vitejs vite, published on 1 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Vite is a frontend tooling framework for javascript. Prior to versions 6.3.4, 6.2.7, 6.1.6, 5.4.19, and 4.5.14, the contents of files in the project root that are denied by a file matching pattern can be returned to the browser. Only apps explicitly exposing the Vite dev server to the network (using --host or server.host config option) are affected. Only files that are under project root and are denied by a file matching pattern can be bypassed. `server.fs.deny` can contain patterns matching against files (by default it includes .env, .env.*, *.{crt,pem} as such patterns). These patterns were able to bypass for files under `root` by using a combination of slash and dot (/.). This issue has been patched in versions 6.3.4, 6.2.7, 6.1.6, 5.4.19, and 4.5.14.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-46565?

10 open source packages ship an affected version, including vite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vite` | npm | All versions | 4.5.14 |
| `vite` | npm | All versions | 4.5.14 |
| `vite` | npm | From 5.0.0 | 5.4.19 |
| `vite` | npm | From 5.0.0 | 5.4.19 |
| `vite` | npm | From 6.0.0 | 6.1.6 |
| `vite` | npm | From 6.0.0 | 6.1.6 |
| `vite` | npm | From 6.2.0 | 6.2.7 |
| `vite` | npm | From 6.2.0 | 6.2.7 |
| `vite` | npm | From 6.3.0 | 6.3.4 |
| `vite` | npm | From 6.3.0 | 6.3.4 |

Products: Vitejs Vite.

## How do I fix CVE-2025-46565?

Upgrade vite to a fixed version for your release line: 4.5.14, 5.4.19, 6.1.6 or 6.2.7.

## Is CVE-2025-46565 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46565 exists.

Public exploit code:

- Vite Dev Server - Information Exposure (nuclei): http/cves/2025/CVE-2025-46565.yaml

## Other vulnerabilities in vitejs vite

- [CVE-2025-31125](https://insights.sbomify.com/CVE-2025-31125/): Vite Vitejs Improper Access Control (medium 5.3, exploited in the wild)
- [CVE-2026-53571](https://insights.sbomify.com/CVE-2026-53571/): Vite: `server.fs.deny` bypass on Windows alternate paths (high 8.2)
- [CVE-2026-39363](https://insights.sbomify.com/CVE-2026-39363/): Vite Affected by Arbitrary File Read via Vite Dev Server WebSocket (high 8.2)
- [CVE-2026-39364](https://insights.sbomify.com/CVE-2026-39364/): Vite has a `server.fs.deny` bypass with queries (high 8.2)
- [CVE-2024-23331](https://insights.sbomify.com/CVE-2024-23331/): Vite dev server option `server.fs.deny` can be bypassed when hosted on case-insensitive filesystem (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46565 and fix it if it is affected.

What it is: CVE-2025-46565 is a medium-severity path traversal vulnerability in vitejs vite, published on 1 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46565 exists.

Affected packages and fixed versions:
- vite (npm): affected all versions; fixed in 4.5.14
- vite (npm): affected all versions; fixed in 4.5.14
- vite (npm): affected from 5.0.0; fixed in 5.4.19
- vite (npm): affected from 5.0.0; fixed in 5.4.19
- vite (npm): affected from 6.0.0; fixed in 6.1.6
- vite (npm): affected from 6.0.0; fixed in 6.1.6
- vite (npm): affected from 6.2.0; fixed in 6.2.7
- vite (npm): affected from 6.2.0; fixed in 6.2.7
- vite (npm): affected from 6.3.0; fixed in 6.3.4
- vite (npm): affected from 6.3.0; fixed in 6.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46565/ (Markdown: https://insights.sbomify.com/CVE-2025-46565/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46565
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46565
- OSV: https://osv.dev/vulnerability/CVE-2025-46565

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46565/
Summaries are generated and may contain mistakes; the official description above is the record.
