CVE-2025-46569 OPA server Data API HTTP path injection of Rego

High 7.4 Published Updated

Attackers can inject Rego code via HTTP paths in OPA server, causing denial of service or erroneous policy decisions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-46569?

CVE-2025-46569 is a high-severity code injection vulnerability in open-policy-agent opa, published on 1 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Open Policy Agent (OPA) is an open source, general-purpose policy engine. Prior to version 1.4.0, when run as a server, OPA exposes an HTTP Data API for reading and writing documents. Requesting a virtual document through the Data API entails policy evaluation, where a Rego query containing a single data document reference is constructed from the requested path. This query is then used for policy evaluation. A HTTP request path can be crafted in a way that injects Rego code into the constructed query. The evaluation result cannot be made to return any other data than what is generated by the requested path, but this path can be misdirected, and the injected Rego code can be crafted to make the query succeed or fail; opening up for oracle attacks or, given the right circumstances, erroneous policy decision results. Furthermore, the injected code can be crafted to be computationally expensive, resulting in a Denial Of Service (DoS) attack. This issue has been patched in version 1.4.0. A workaround involves having network access to OPA’s RESTful APIs being limited to `localhost` and/or trusted networks, unless necessary for production reasons.

Weakness: CWE-94, CWE-863

Which versions are affected by CVE-2025-46569?

7 open source packages ship an affected version, including github.com/open-policy-agent/opa, github.com/open-policy-agent/opa/server and github.com/open-policy-agent/opa/v1/server.

PackageAffectedFixed in
github.com/open-policy-agent/opa GoAll versions1.4.0
github.com/open-policy-agent/opa GoAll versions1.4.0
github.com/open-policy-agent/opa GoAll versions1.4.0
github.com/open-policy-agent/opa/server GoAll versions1.4.0
github.com/open-policy-agent/opa/server GoAll versions1.4.0
github.com/open-policy-agent/opa/v1/server GoAll versions1.4.0
1 more packages
github.com/open-policy-agent/opa/v1/server GoAll versions1.4.0
Linux distribution packages (16)
cosign SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOSAll versions2.5.3-150400.3.30.1
cosign SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSSAll versions2.5.3-150400.3.30.1
cosign SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOSAll versions2.5.3-150400.3.30.1
cosign SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSSAll versions2.5.3-150400.3.30.1
cosign SUSE:Linux Enterprise Module for Basesystem 15 SP6All versions2.5.3-150400.3.30.1
cosign SUSE:Linux Enterprise Module for Basesystem 15 SP7All versions2.5.3-150400.3.30.1
cosign SUSE:Linux Enterprise Server 15 SP4-LTSSAll versions2.5.3-150400.3.30.1
cosign SUSE:Linux Enterprise Server 15 SP5-LTSSAll versions2.5.3-150400.3.30.1
cosign SUSE:Linux Enterprise Server for SAP Applications 15 SP4All versions2.5.3-150400.3.30.1
cosign SUSE:Linux Enterprise Server for SAP Applications 15 SP5All versions2.5.3-150400.3.30.1
cosign SUSE:Manager Proxy 4.3All versions2.5.3-150400.3.30.1
cosign SUSE:Manager Server 4.3All versions2.5.3-150400.3.30.1
cosign openSUSE:Leap 15.6All versions2.5.3-150400.3.30.1
cosign openSUSE:TumbleweedAll versions2.5.3-1.1
hauler openSUSE:TumbleweedAll versions1.2.5-1.1
trivy openSUSE:TumbleweedAll versions0.65.0-2.1

How do I fix CVE-2025-46569?

Upgrade github.com/open-policy-agent/opa to 1.4.0 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2025-46569 being exploited?

There is no known exploitation of CVE-2025-46569 in the wild and no public exploit code.

Sources

Also known as AZL-63067, CLEANSTART-2026-OK69185, CLEANSTART-2026-PU21054, ECHO-4d87-77fe-13dc, GHSA-6m8w-jc87-6cr7, GO-2025-3660 and 12 more.

Is CVE-2025-46569 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free