# CVE-2025-46570: vLLM’s Chunk-Based Prefix Caching Vulnerable to Potential Timing Side-Channel

> Attackers can exploit timing differences in prefix caching to infer sensitive information about processed prompts in vLLM.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 May 2025
- **Updated:** 29 May 2025
- **Also known as:** GHSA-4qjh-9fv9-r85r, PYSEC-2025-53

## What is CVE-2025-46570?

CVE-2025-46570 is a low-severity vulnerability in Vllm Vllm, published on 29 May 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). Prior to version 0.9.0, when a new prompt is processed, if the PageAttention mechanism finds a matching prefix chunk, the prefill process speeds up, which is reflected in the TTFT (Time to First Token). These timing differences caused by matching chunks are significant enough to be recognized and exploited. This issue has been patched in version 0.9.0.

Weakness: CWE-203 (Observable Discrepancy), CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2025-46570?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.9.0 |
| `vllm` | PyPI | All versions | 0.9.0 |
| `vllm` | PyPI | All versions | 0.9.0 |

Products: Vllm Vllm.

## How do I fix CVE-2025-46570?

Upgrade vllm to 0.9.0 or later.

## Is CVE-2025-46570 being exploited?

There is no known exploitation of CVE-2025-46570 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46570 and fix it if it is affected.

What it is: CVE-2025-46570 is a low-severity vulnerability in Vllm Vllm, published on 29 May 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-46570 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.9.0
- vllm (PyPI): affected all versions; fixed in 0.9.0
- vllm (PyPI): affected all versions; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46570/ (Markdown: https://insights.sbomify.com/CVE-2025-46570/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46570
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46570
- OSV: https://osv.dev/vulnerability/CVE-2025-46570

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46570/
Summaries are generated and may contain mistakes; the official description above is the record.
