# CVE-2025-46571: Open WebUI vulnerable to limited stored XSS vila uploaded html file

> Low-privileged users can upload malicious HTML files to trigger stored XSS, potentially leading to admin account takeover and remote code execution.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 May 2025
- **Updated:** 5 May 2025
- **Also known as:** GHSA-8gh5-qqh8-hq3x, PYSEC-2026-2713

## What is CVE-2025-46571?

CVE-2025-46571 is a medium-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 5 May 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Prior to version 0.6.6, low privileged users can upload HTML files which contain JavaScript code via the `/api/v1/files/` backend endpoint. This endpoint returns a file id, which can be used to open the file in the browser and trigger the JavaScript code in the user's browser. Under the default settings, files uploaded by low-privileged users can only be viewed by admins or themselves, limiting the impact of this vulnerability. A link to such a file can be sent to an admin, and if clicked, will give the low-privileged user complete control over the admin's account, ultimately enabling RCE via functions. Version 0.6.6 contains a fix for the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-46571?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.6.6 |
| `open-webui` | PyPI | All versions | 0.6.6 |
| `open-webui` | PyPI | All versions | 0.6.6 |

Products: Openwebui Open Webui.

## How do I fix CVE-2025-46571?

Upgrade open-webui to 0.6.6 or later.

## Is CVE-2025-46571 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46571 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46571 and fix it if it is affected.

What it is: CVE-2025-46571 is a medium-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 5 May 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46571 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.6.6
- open-webui (PyPI): affected all versions; fixed in 0.6.6
- open-webui (PyPI): affected all versions; fixed in 0.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46571/ (Markdown: https://insights.sbomify.com/CVE-2025-46571/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46571
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46571
- OSV: https://osv.dev/vulnerability/CVE-2025-46571

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46571/
Summaries are generated and may contain mistakes; the official description above is the record.
