{"answers":{"affected":"2 open source packages ship an affected version, including passport-wsfed-saml2.","exploited":"There is no known exploitation of CVE-2025-46573 in the wild and no public exploit code.","fix":"Upgrade passport-wsfed-saml2 to 4.6.4 or later.","what":"CVE-2025-46573 is a high-severity authentication bypass vulnerability in auth0 passport-wsfed-saml2, published on 6 May 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-46573 and fix it if it is affected.\n\nWhat it is: CVE-2025-46573 is a high-severity authentication bypass vulnerability in auth0 passport-wsfed-saml2, published on 6 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-46573 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- passport-wsfed-saml2 (npm): affected from 3.0.5; fixed in 4.6.4\n- passport-wsfed-saml2 (npm): affected from 3.0.5; fixed in 4.6.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-46573/ (Markdown: https://insights.sbomify.com/CVE-2025-46573/index.md)","id":"CVE-2025-46573","markdown":"https://insights.sbomify.com/CVE-2025-46573/index.md","name":"CVE-2025-46573","record":{"aliases":["GHSA-8gqj-226h-gm8r"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js SAML library","requires_auth":"low_privilege","summary":"Attackers can impersonate users by tampering with SAML responses in passport-wsfed-saml2, leading to account takeover.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"passport-wsfed-saml2 provides passport strategy for both WS-fed and SAML2 protocol. A vulnerability present starting in version 3.0.5 up to and including version 4.6.3 allows an attacker to impersonate any user during SAML authentication by tampering with a valid SAML response. This can be done by adding attributes to the response. Users are affected specifically when the service provider is using `passport-wsfed-saml2` and a valid SAML Response signed by the Identity Provider can be obtained. Version 4.6.4 contains a fix for the vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"passport-wsfed-saml2 Has SAML Authentication Bypass via Attribute Smuggling","id":"CVE-2025-46573","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"ZTE GoldenDB Database product has an input validation vulnerability","id":"CVE-2025-46574"},"packages":[{"ecosystem":"npm","fixed":["4.6.4"],"introduced":["3.0.5"],"last_affected":[],"package":"passport-wsfed-saml2","purl":null,"source":"GHSA-8gqj-226h-gm8r"},{"ecosystem":"npm","fixed":["4.6.4"],"introduced":["3.0.5"],"last_affected":[],"package":"passport-wsfed-saml2","purl":"pkg:npm/passport-wsfed-saml2","source":"GHSA-8gqj-226h-gm8r"}],"prev":{"headline":"passport-wsfed-saml2 Has SAML Authentication Bypass via Signature Wrapping","id":"CVE-2025-46572"},"products":["passport-wsfed-saml2"],"published":"2025-05-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-07","vendors":["auth0"]},"summary":"Attackers can impersonate users by tampering with SAML responses in passport-wsfed-saml2, leading to account takeover.","url":"https://insights.sbomify.com/CVE-2025-46573/"}