# CVE-2025-46573: passport-wsfed-saml2 Has SAML Authentication Bypass via Attribute Smuggling

> Attackers can impersonate users by tampering with SAML responses in passport-wsfed-saml2, leading to account takeover.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2025
- **Updated:** 7 May 2025
- **Also known as:** GHSA-8gqj-226h-gm8r

## What is CVE-2025-46573?

CVE-2025-46573 is a high-severity authentication bypass vulnerability in auth0 passport-wsfed-saml2, published on 6 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

passport-wsfed-saml2 provides passport strategy for both WS-fed and SAML2 protocol. A vulnerability present starting in version 3.0.5 up to and including version 4.6.3 allows an attacker to impersonate any user during SAML authentication by tampering with a valid SAML response. This can be done by adding attributes to the response. Users are affected specifically when the service provider is using `passport-wsfed-saml2` and a valid SAML Response signed by the Identity Provider can be obtained. Version 4.6.4 contains a fix for the vulnerability.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-46573?

2 open source packages ship an affected version, including passport-wsfed-saml2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `passport-wsfed-saml2` | npm | From 3.0.5 | 4.6.4 |
| `passport-wsfed-saml2` | npm | From 3.0.5 | 4.6.4 |

## How do I fix CVE-2025-46573?

Upgrade passport-wsfed-saml2 to 4.6.4 or later.

## Is CVE-2025-46573 being exploited?

There is no known exploitation of CVE-2025-46573 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46573 and fix it if it is affected.

What it is: CVE-2025-46573 is a high-severity authentication bypass vulnerability in auth0 passport-wsfed-saml2, published on 6 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-46573 in the wild and no public exploit code.

Affected packages and fixed versions:
- passport-wsfed-saml2 (npm): affected from 3.0.5; fixed in 4.6.4
- passport-wsfed-saml2 (npm): affected from 3.0.5; fixed in 4.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46573/ (Markdown: https://insights.sbomify.com/CVE-2025-46573/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46573
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46573
- OSV: https://osv.dev/vulnerability/CVE-2025-46573

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46573/
Summaries are generated and may contain mistakes; the official description above is the record.
