{"answers":{"affected":"3 open source packages ship an affected version, including github.com/openpubkey/opkssh. It affects 2 products.","exploited":"There is no known exploitation of CVE-2025-4658 in the wild and no public exploit code.","fix":"Upgrade github.com/openpubkey/opkssh to 0.5.0 or later.","what":"CVE-2025-4658 is a critical authentication bypass vulnerability in OPKSSH, published on 13 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-4658 and fix it if it is affected.\n\nWhat it is: CVE-2025-4658 is a critical authentication bypass vulnerability in OPKSSH, published on 13 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-4658 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/openpubkey/opkssh (Go): affected all versions; fixed in 0.5.0\n- github.com/openpubkey/opkssh (Go): affected all versions; fixed in 0.5.0\n- github.com/openpubkey/opkssh (Go): affected all versions; fixed in 0.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-4658/ (Markdown: https://insights.sbomify.com/CVE-2025-4658/index.md)","id":"CVE-2025-4658","markdown":"https://insights.sbomify.com/CVE-2025-4658/index.md","name":"CVE-2025-4658","record":{"aliases":["GHSA-56wx-66px-9j66","GO-2025-3680","UBUNTU-CVE-2025-4658"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenPubkey library","requires_auth":"none","summary":"Attackers can bypass authentication in OPKSSH by crafting a malicious JWS that evades signature verification in the underlying OpenPubkey library.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"cloudflare","cpe":[{"product":"openpubkey","vendor":"openpubkey"},{"product":"opkssh","vendor":"openpubkey"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L","version":"4.0"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"},{"id":"CWE-305","name":"Authentication Bypass by Primary Weakness"}],"description":"Versions of OpenPubkey library prior to 0.10.0  contained a vulnerability that would allow a specially crafted JWS to bypass signature verification. As OPKSSH depends on the OpenPubkey library for authentication, this vulnerability in OpenPubkey also applies to OPKSSH versions prior to 0.5.0 and would allow an attacker to bypass OPKSSH authentication.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authentication Bypass in OPKSSH","id":"CVE-2025-4658","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Information disclosure in Integration for Salesforce and Contact Form 7, WPForms, Elementor, Formidable, Ninja Forms","id":"CVE-2025-4659"},"packages":[{"ecosystem":"Go","fixed":["0.5.0"],"introduced":["0"],"last_affected":[],"package":"github.com/openpubkey/opkssh","purl":null,"source":"GHSA-56wx-66px-9j66"},{"ecosystem":"Go","fixed":["0.5.0"],"introduced":["0"],"last_affected":[],"package":"github.com/openpubkey/opkssh","purl":"pkg:golang/github.com/openpubkey/opkssh","source":"GHSA-56wx-66px-9j66"},{"ecosystem":"Go","fixed":["0.5.0"],"introduced":["0"],"last_affected":[],"package":"github.com/openpubkey/opkssh","purl":"pkg:golang/github.com/openpubkey/opkssh","source":"GO-2025-3680"}],"prev":{"headline":"Memory corruption in App Store","id":"CVE-2025-4657"},"products":["OPKSSH"],"published":"2025-05-13","related":[{"cvss_score":9.3,"headline":"Authentication Bypass in OpenPubKey","id":"CVE-2025-3757","kev_date_added":null,"published":"2025-05-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-13","vendors":["OPKSSH"]},"summary":"Attackers can bypass authentication in OPKSSH by crafting a malicious JWS that evades signature verification in the underlying OpenPubkey library.","url":"https://insights.sbomify.com/CVE-2025-4658/"}