# CVE-2025-4658: Authentication Bypass in OPKSSH

> Attackers can bypass authentication in OPKSSH by crafting a malicious JWS that evades signature verification in the underlying OpenPubkey library.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2025
- **Updated:** 13 May 2025
- **Also known as:** GHSA-56wx-66px-9j66, GO-2025-3680, UBUNTU-CVE-2025-4658

## What is CVE-2025-4658?

CVE-2025-4658 is a critical authentication bypass vulnerability in OPKSSH, published on 13 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of OpenPubkey library prior to 0.10.0  contained a vulnerability that would allow a specially crafted JWS to bypass signature verification. As OPKSSH depends on the OpenPubkey library for authentication, this vulnerability in OpenPubkey also applies to OPKSSH versions prior to 0.5.0 and would allow an attacker to bypass OPKSSH authentication.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-305 (Authentication Bypass by Primary Weakness)

## Which versions are affected by CVE-2025-4658?

3 open source packages ship an affected version, including github.com/openpubkey/opkssh. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openpubkey/opkssh` | Go | All versions | 0.5.0 |
| `github.com/openpubkey/opkssh` | Go | All versions | 0.5.0 |
| `github.com/openpubkey/opkssh` | Go | All versions | 0.5.0 |

Products: Openpubkey Openpubkey, Openpubkey Opkssh.

## How do I fix CVE-2025-4658?

Upgrade github.com/openpubkey/opkssh to 0.5.0 or later.

## Is CVE-2025-4658 being exploited?

There is no known exploitation of CVE-2025-4658 in the wild and no public exploit code.

## Other vulnerabilities in OPKSSH

- [CVE-2025-3757](https://insights.sbomify.com/CVE-2025-3757/): Authentication Bypass in OpenPubKey (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4658 and fix it if it is affected.

What it is: CVE-2025-4658 is a critical authentication bypass vulnerability in OPKSSH, published on 13 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-4658 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openpubkey/opkssh (Go): affected all versions; fixed in 0.5.0
- github.com/openpubkey/opkssh (Go): affected all versions; fixed in 0.5.0
- github.com/openpubkey/opkssh (Go): affected all versions; fixed in 0.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4658/ (Markdown: https://insights.sbomify.com/CVE-2025-4658/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4658
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4658
- OSV: https://osv.dev/vulnerability/CVE-2025-4658

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4658/
Summaries are generated and may contain mistakes; the official description above is the record.
