# CVE-2025-46619: Path traversal in n/a

> Attackers can access sensitive system files like /etc/passwd via path traversal in Couchbase Server, requiring an upgrade to secure the database.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 Apr 2025
- **Updated:** 1 May 2025
- **Also known as:** GHSA-fv83-m6v9-qw8v

## What is CVE-2025-46619?

CVE-2025-46619 is a high-severity path traversal vulnerability in Couchbase Couchbase Server, published on 30 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A security issue has been discovered in Couchbase Server before 7.6.4 and fixed in v.7.6.4 and v.7.2.7 for Windows that could allow unauthorized access to sensitive files. Depending on the level of privileges, this vulnerability may grant access to files such as /etc/passwd or /etc/shadow.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-46619?

It affects 1 product.


Products: Couchbase Couchbase Server.

## How do I fix CVE-2025-46619?

No fix has been published for CVE-2025-46619 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-46619 being exploited?

There is no known exploitation of CVE-2025-46619 in the wild and no public exploit code.

## Other vulnerabilities in Couchbase Couchbase Server

- [CVE-2024-0519](https://insights.sbomify.com/CVE-2024-0519/): Google Chromium V8 Out-of-Bounds Memory Access (high 8.8, exploited in the wild)
- [CVE-2023-3079](https://insights.sbomify.com/CVE-2023-3079/): Google Chromium V8 Type Confusion (high 8.8, exploited in the wild)
- [CVE-2023-2033](https://insights.sbomify.com/CVE-2023-2033/): Google Chromium V8 Type Confusion (high 8.8, exploited in the wild)
- [CVE-2023-49930](https://insights.sbomify.com/CVE-2023-49930/): Missing authorization in n/a (critical 9.8)
- [CVE-2023-49931](https://insights.sbomify.com/CVE-2023-49931/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46619 and fix it if it is affected.

What it is: CVE-2025-46619 is a high-severity path traversal vulnerability in Couchbase Couchbase Server, published on 30 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-46619 in the wild and no public exploit code.

Affected product: Couchbase Couchbase Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46619/ (Markdown: https://insights.sbomify.com/CVE-2025-46619/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46619
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46619
- OSV: https://osv.dev/vulnerability/CVE-2025-46619

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46619/
Summaries are generated and may contain mistakes; the official description above is the record.
