# CVE-2025-46647: Apache APISIX: improper validation of issuer from introspection discovery url in plugin openid-connect

> Attackers can bypass authentication to access other issuers if multiple issuers share keys in APISIX openid-connect introspection mode.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jul 2025
- **Updated:** 4 Nov 2025
- **Also known as:** BIT-apisix-2025-46647, GHSA-495r-5j65-5hp3

## What is CVE-2025-46647?

CVE-2025-46647 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 2 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability of plugin openid-connect in Apache APISIX.

This vulnerability will only have an impact if all of the following conditions are met:
1. Use the openid-connect plugin with introspection mode
2. The auth service connected to openid-connect provides services to multiple issuers
3. Multiple issuers share the same private key and relies only on the issuer being different

If affected by this vulnerability, it would allow an attacker with a valid account on one of the issuers to log into the other issuer.

This issue affects Apache APISIX: until 3.12.0.

Users are recommended to upgrade to version 3.12.0 or higher.

Weakness: CWE-302 (Authentication Bypass by Assumed-Immutable Data)

## Which versions are affected by CVE-2025-46647?

1 open source package ship an affected version, including apisix. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apisix` | Bitnami | All versions | 3.12.0 |

Products: Apache Apisix.

## How do I fix CVE-2025-46647?

Upgrade apisix to 3.12.0 or later.

## Is CVE-2025-46647 being exploited?

There is no known exploitation of CVE-2025-46647 in the wild and no public exploit code.

## Other vulnerabilities in Apache APISIX

- [CVE-2022-24112](https://insights.sbomify.com/CVE-2022-24112/): Apache APISIX Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2022-25757](https://insights.sbomify.com/CVE-2022-25757/): Apache APISIX: the body_schema check in request-validation plugin can be bypassed (critical 9.8)
- [CVE-2026-31908](https://insights.sbomify.com/CVE-2026-31908/): Apache APISIX: forward auth plugin allows header injection (critical 9.1)
- [CVE-2026-75005](https://insights.sbomify.com/CVE-2026-75005/): Apache APISIX: Unauthenticated CPU-exhaustion DoS (high 8.7)
- [CVE-2025-27446](https://insights.sbomify.com/CVE-2025-27446/): Privilege escalation in Apache APISIX Java Plugin Runner (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46647 and fix it if it is affected.

What it is: CVE-2025-46647 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 2 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-46647 in the wild and no public exploit code.

Affected packages and fixed versions:
- apisix (Bitnami): affected all versions; fixed in 3.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46647/ (Markdown: https://insights.sbomify.com/CVE-2025-46647/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46647
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46647
- OSV: https://osv.dev/vulnerability/CVE-2025-46647

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46647/
Summaries are generated and may contain mistakes; the official description above is the record.
