# CVE-2025-46656: markdownify allows large headline prefixes such as <h9999999>, which causes memory consumption

> An attacker can cause memory exhaustion and denial of service by providing large headline prefixes to the markdownify library.

- **Severity:** Low 2.9 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Apr 2025
- **Updated:** 29 Apr 2025
- **Also known as:** GHSA-7mpr-5m44-h73r, PYSEC-2026-1604

## What is CVE-2025-46656?

CVE-2025-46656 is a low-severity denial of service vulnerability in python-markdownify, published on 26 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

python-markdownify (aka markdownify) before 0.14.1 allows large headline prefixes such as <h9999999> in addition to <h1> through <h6>. This causes memory consumption.

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2025-46656?

3 open source packages ship an affected version, including markdownify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `markdownify` | PyPI | All versions | 0.14.1 |
| `markdownify` | PyPI | All versions | 0.14.1 |
| `markdownify` | PyPI | All versions | 0.14.1 |

Products: Matthewwithanm Markdownify.

## How do I fix CVE-2025-46656?

Upgrade markdownify to 0.14.1 or later.

## Is CVE-2025-46656 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46656 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46656 and fix it if it is affected.

What it is: CVE-2025-46656 is a low-severity denial of service vulnerability in python-markdownify, published on 26 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46656 exists.

Affected packages and fixed versions:
- markdownify (PyPI): affected all versions; fixed in 0.14.1
- markdownify (PyPI): affected all versions; fixed in 0.14.1
- markdownify (PyPI): affected all versions; fixed in 0.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46656/ (Markdown: https://insights.sbomify.com/CVE-2025-46656/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46656
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46656
- OSV: https://osv.dev/vulnerability/CVE-2025-46656

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46656/
Summaries are generated and may contain mistakes; the official description above is the record.
