# CVE-2025-46686: Denial of service in Redis

> An authenticated user can cause memory exhaustion and denial of service by sending multi-bulk commands with many arguments.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jul 2025
- **Updated:** 26 Aug 2025
- **Also known as:** BIT-keydb-2025-46686, BIT-redis-2025-46686, BIT-valkey-2025-46686, DEBIAN-CVE-2025-46686, ECHO-074a-b4a7-532d, GHSA-2r7g-8hpc-rpq9, GHSA-f46f-fjf4-h4m2, MINI-fgg9-x5r5-53p7, MINI-gx77-cwc2-3f2p, MINI-m9p9-vccg-mhvf, MINI-wh88-j56g-hpjr, UBUNTU-CVE-2025-46686

## What is CVE-2025-46686?

CVE-2025-46686 is a low-severity denial of service vulnerability in Redis, published on 23 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Redis through 8.0.3 allows memory consumption via a multi-bulk command composed of many bulks, sent by an authenticated user. This occurs because the server allocates memory for the command arguments of every bulk, even when the command is skipped because of insufficient permissions. NOTE: this is disputed by the Supplier because abuse of the commands network protocol is not a violation of the Redis Security Model.

Weakness: CWE-401 (Missing Release of Memory after Effective Lifetime)

## Which versions are affected by CVE-2025-46686?

3 open source packages ship an affected version, including redis, keydb and valkey.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `redis` | Bitnami | All versions | 8.0.4 |
| `keydb` | Bitnami | All versions to 8.0.3 | None |
| `valkey` | Bitnami | All versions | 8.0.4 |

## How do I fix CVE-2025-46686?

Upgrade redis to 8.0.4 or later.

## Is CVE-2025-46686 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46686 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46686 and fix it if it is affected.

What it is: CVE-2025-46686 is a low-severity denial of service vulnerability in Redis, published on 23 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46686 exists.

Affected packages and fixed versions:
- redis (Bitnami): affected all versions; fixed in 8.0.4
- keydb (Bitnami): affected all versions up to 8.0.3; no fix listed
- valkey (Bitnami): affected all versions; fixed in 8.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46686/ (Markdown: https://insights.sbomify.com/CVE-2025-46686/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46686
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46686
- OSV: https://osv.dev/vulnerability/CVE-2025-46686

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46686/
Summaries are generated and may contain mistakes; the official description above is the record.
