CVE-2025-46701 Apache Tomcat: Security constraint bypass for CGI scripts
Attackers can bypass security constraints on CGI scripts in Apache Tomcat by exploiting case sensitivity issues in URI pathInfo handling.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-46701?
CVE-2025-46701 is a high-severity vulnerability in Apache Tomcat, published on 29 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.
Weakness: CWE-178
Which versions are affected by CVE-2025-46701?
17 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-catalina. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.41 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.41 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.7 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.7 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 to 8.5.100 | None |
11 more packages
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.105 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.105 |
tomcat Bitnami | All versions | 9.0.105, 10.1.41, 11.0.7 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.41 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.41 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.7 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.7 |
org.apache.tomcat:tomcat-catalina Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat-catalina Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.0.M1 | 9.0.105 |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.0.M1 | 9.0.105 |
Products include Apache Tomcat.
How do I fix CVE-2025-46701?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.41, 11.0.7 or 9.0.105.
Is CVE-2025-46701 being exploited?
There is no known exploitation of CVE-2025-46701 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2025-46701, DEBIAN-CVE-2025-46701, GHSA-h2fw-rfh5-95r3, MGASA-2025-0177, OESA-2025-1641, ROOT-APP-MAVEN-CVE-2025-46701 and 1 more.