CVE-2025-46702 Mattermost Playbooks allows privilege escalation through improper access control in playbook run participant management

Medium 5.4 Published Updated

Authenticated users can bypass permission restrictions to manage private channel members, leading to privilege escalation and unauthorized data access.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-46702?

CVE-2025-46702 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 30 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 10.5.x <= 10.5.5, 9.11.x <= 9.11.15, 10.8.x <= 10.8.0, 10.7.x <= 10.7.2, 10.6.x <= 10.6.5 fail to properly enforce channel member management permissions when adding participants to playbook runs. This allows authenticated users with member-level permissions to bypass system admin restrictions and add or remove users to/from private channels via the playbook run participants feature, even when the 'Manage Members' permission has been explicitly removed. This can lead to unauthorized access to sensitive channel content and allow guest users to gain channel management privileges.

Weakness: CWE-863

Which versions are affected by CVE-2025-46702?

18 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250513065225-4ae5d647fb88
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250513065225-4ae5d647fb88
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250513065225-4ae5d647fb88
github.com/mattermost/mattermost/server/v8 GoFrom 10.5.010.5.6
github.com/mattermost/mattermost/server/v8 GoFrom 10.5.010.5.6
github.com/mattermost/mattermost/server/v8 GoFrom 10.6.010.6.6
12 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 10.6.010.6.6
github.com/mattermost/mattermost/server/v8 GoFrom 10.7.010.7.3
github.com/mattermost/mattermost/server/v8 GoFrom 10.7.010.7.3
github.com/mattermost/mattermost/server/v8 GoFrom 10.8.010.8.1
github.com/mattermost/mattermost/server/v8 GoFrom 10.8.010.8.1
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.09.11.16
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.09.11.16
github.com/mattermost/mattermost-server GoAll versions0.0.0-20250513065225-4ae5d647fb88, 9.11.16+incompatible, 10.5.6+incompatible, 10.6.6+incompatible, 10.7.3+incompatible, 10.8.1+incompatible
github.com/mattermost/mattermost-server GoAll versions0.0.0-20250513065225-4ae5d647fb88
github.com/mattermost/mattermost-server GoAll versions0.0.0-20250513065225-4ae5d647fb88
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost Server.

How do I fix CVE-2025-46702?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250513065225-4ae5d647fb88, 10.5.6, 10.6.6 or 10.7.3.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-46702 being exploited?

There is no known exploitation of CVE-2025-46702 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-v8fr-vxmw-6mf6, GO-2025-3796.

Is CVE-2025-46702 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free