# CVE-2025-46712: Erlang/OTP SSH Has Strict KEX Violations

> A Man-in-the-Middle attacker can bypass SSH handshake hardening measures in Erlang/OTP by injecting optional messages during the key exchange.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2025
- **Updated:** 12 Jan 2026
- **Also known as:** AZL-61744, AZL-61748, CLEANSTART-2026-LK44772, DEBIAN-CVE-2025-46712, GHSA-934x-xq38-hhqf, OESA-2025-1552, OESA-2025-1553, UBUNTU-CVE-2025-46712

## What is CVE-2025-46712?

CVE-2025-46712 is a low-severity vulnerability in erlang otp, published on 8 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Erlang/OTP is a set of libraries for the Erlang programming language. In versions prior to OTP-27.3.4 (for OTP-27), OTP-26.2.5.12 (for OTP-26), and OTP-25.3.2.21 (for OTP-25), Erlang/OTP SSH fails to enforce strict KEX handshake hardening measures by allowing optional messages to be exchanged. This allows a Man-in-the-Middle attacker to inject these messages in a connection during the handshake. This issue has been patched in versions OTP-27.3.4 (for OTP-27), OTP-26.2.5.12 (for OTP-26), and OTP-25.3.2.21 (for OTP-25).

Weakness: CWE-440 (Expected Behavior Violation)

## Which versions are affected by CVE-2025-46712?


## How do I fix CVE-2025-46712?

Upgrade to a fixed version.

## Is CVE-2025-46712 being exploited?

There is no known exploitation of CVE-2025-46712 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46712 and fix it if it is affected.

What it is: CVE-2025-46712 is a low-severity vulnerability in erlang otp, published on 8 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-46712 in the wild and no public exploit code.

Affected product: erlang otp. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46712/ (Markdown: https://insights.sbomify.com/CVE-2025-46712/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46712
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46712
- OSV: https://osv.dev/vulnerability/CVE-2025-46712

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46712/
Summaries are generated and may contain mistakes; the official description above is the record.
