{"answers":{"affected":"2 open source packages ship an affected version, including sudo-rs. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46718 exists.","fix":"Upgrade sudo-rs to 0.2.6 or later.","what":"CVE-2025-46718 is a low-severity vulnerability in trifectatechfoundation sudo-rs, published on 12 May 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-46718 and fix it if it is affected.\n\nWhat it is: CVE-2025-46718 is a low-severity vulnerability in trifectatechfoundation sudo-rs, published on 12 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46718 exists.\n\nAffected packages and fixed versions:\n- sudo-rs (crates.io): affected all versions; fixed in 0.2.6\n- sudo-rs (crates.io): affected all versions; fixed in 0.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-46718/ (Markdown: https://insights.sbomify.com/CVE-2025-46718/index.md)","id":"CVE-2025-46718","markdown":"https://insights.sbomify.com/CVE-2025-46718/index.md","name":"CVE-2025-46718","record":{"aliases":["DEBIAN-CVE-2025-46718","GHSA-w9q3-g4p5-5q2r","MINI-74c9-5r2f-rm74","UBUNTU-CVE-2025-46718"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"sudo-rs utility","requires_auth":"low_privilege","summary":"Low-privilege users can enumerate other users' sudo permissions, exposing sensitive configuration details useful for targeted attacks.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sudo","vendor":"trifectatech"}],"cvss":{"score":3.3,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-497","name":"Exposure of Sensitive System Information to an Unauthorized Control Sphere"}],"description":"sudo-rs is a memory safe implementation of sudo and su written in Rust. Prior to version 0.2.6, users with limited sudo privileges (e.g. execution of a single command) can list sudo privileges of other users using the `-U` flag. This vulnerability allows users with limited sudo privileges to enumerate the sudoers file, revealing sensitive information about other users' permissions. Attackers can collect information that can be used to more targeted attacks. Systems where users either do not have sudo privileges or have the ability to run all commands as root through sudo (the default configuration on most systems) are not affected by this advisory. Version 0.2.6 fixes the vulnerability.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"sudo-rs Allows Low Privilege Users to Enumerate Privileges of Others","id":"CVE-2025-46718","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Open WebUI vulnerable to stored XSS via unescaped markdown token in MarkdownTokens.svelte leading to full account takeover and RCE via functions","id":"CVE-2025-46719"},"packages":[{"ecosystem":"crates.io","fixed":["0.2.6"],"introduced":["0"],"last_affected":[],"package":"sudo-rs","purl":null,"source":"GHSA-w9q3-g4p5-5q2r"},{"ecosystem":"crates.io","fixed":["0.2.6"],"introduced":["0"],"last_affected":[],"package":"sudo-rs","purl":"pkg:cargo/sudo-rs","source":"GHSA-w9q3-g4p5-5q2r"}],"prev":{"headline":"sudo-rs Allows Low Privilege Users to Discover the Existence of Files in Inaccessible Folders","id":"CVE-2025-46717"},"products":["sudo-rs"],"published":"2025-05-12","related":[{"cvss_score":3.3,"headline":"sudo-rs Allows Low Privilege Users to Discover the Existence of Files in Inaccessible Folders","id":"CVE-2025-46717","kev_date_added":null,"published":"2025-05-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-12","vendors":["trifectatechfoundation"]},"summary":"Low-privilege users can enumerate other users' sudo permissions, exposing sensitive configuration details useful for targeted attacks.","url":"https://insights.sbomify.com/CVE-2025-46718/"}