# CVE-2025-46718: sudo-rs Allows Low Privilege Users to Enumerate Privileges of Others

> Low-privilege users can enumerate other users' sudo permissions, exposing sensitive configuration details useful for targeted attacks.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2025
- **Updated:** 12 May 2025
- **Also known as:** DEBIAN-CVE-2025-46718, GHSA-w9q3-g4p5-5q2r, MINI-74c9-5r2f-rm74, UBUNTU-CVE-2025-46718

## What is CVE-2025-46718?

CVE-2025-46718 is a low-severity vulnerability in trifectatechfoundation sudo-rs, published on 12 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

sudo-rs is a memory safe implementation of sudo and su written in Rust. Prior to version 0.2.6, users with limited sudo privileges (e.g. execution of a single command) can list sudo privileges of other users using the `-U` flag. This vulnerability allows users with limited sudo privileges to enumerate the sudoers file, revealing sensitive information about other users' permissions. Attackers can collect information that can be used to more targeted attacks. Systems where users either do not have sudo privileges or have the ability to run all commands as root through sudo (the default configuration on most systems) are not affected by this advisory. Version 0.2.6 fixes the vulnerability.

Weakness: CWE-497 (Exposure of Sensitive System Information to an Unauthorized Control Sphere)

## Which versions are affected by CVE-2025-46718?

2 open source packages ship an affected version, including sudo-rs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sudo-rs` | crates.io | All versions | 0.2.6 |
| `sudo-rs` | crates.io | All versions | 0.2.6 |

Products: Trifectatech Sudo.

## How do I fix CVE-2025-46718?

Upgrade sudo-rs to 0.2.6 or later.

## Is CVE-2025-46718 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46718 exists.

## Other vulnerabilities in trifectatechfoundation sudo-rs

- [CVE-2025-46717](https://insights.sbomify.com/CVE-2025-46717/): sudo-rs Allows Low Privilege Users to Discover the Existence of Files in Inaccessible Folders (low 3.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46718 and fix it if it is affected.

What it is: CVE-2025-46718 is a low-severity vulnerability in trifectatechfoundation sudo-rs, published on 12 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46718 exists.

Affected packages and fixed versions:
- sudo-rs (crates.io): affected all versions; fixed in 0.2.6
- sudo-rs (crates.io): affected all versions; fixed in 0.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46718/ (Markdown: https://insights.sbomify.com/CVE-2025-46718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46718
- OSV: https://osv.dev/vulnerability/CVE-2025-46718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46718/
Summaries are generated and may contain mistakes; the official description above is the record.
