# CVE-2025-46719: Open WebUI vulnerable to stored XSS via unescaped markdown token in MarkdownTokens.svelte leading to full account takeover and RCE via functions

> Attackers can inject JavaScript into chat transcripts to steal access tokens, take over accounts, and achieve remote code execution on the server.

- **Severity:** Medium 5.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 May 2025
- **Updated:** 5 May 2025
- **Also known as:** GHSA-9f4f-jv96-8766, PYSEC-2026-2716

## What is CVE-2025-46719?

CVE-2025-46719 is a medium-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 5 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Prior to version 0.6.6, a vulnerability in the way certain html tags in chat messages are rendered allows attackers to inject JavaScript code into a chat transcript. The JavaScript code will be executed in the user's browser every time that chat transcript is opened, allowing attackers to retrieve the user's access token and gain full control over their account. Chat transcripts can be shared with other users in the same server, or with the whole open-webui community if "Enable Community Sharing" is enabled in the admin panel. If this exploit is used against an admin user, it is possible to achieve Remote Code Execution on the server where the open-webui backend is hosted. This can be done by creating a new function which contains malicious python code. This vulnerability also affects chat transcripts uploaded to `https://openwebui.com/c/<user>/<chat_id>`, allowing for wormable stored XSS in https[:]//openwebui[.]com. Version 0.6.6 contains a patch for the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-46719?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.6.6 |
| `open-webui` | PyPI | All versions | 0.6.6 |
| `open-webui` | PyPI | All versions | 0.6.6 |

Products: Openwebui Open Webui.

## How do I fix CVE-2025-46719?

Upgrade open-webui to 0.6.6 or later.

## Is CVE-2025-46719 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46719 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46719 and fix it if it is affected.

What it is: CVE-2025-46719 is a medium-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 5 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46719 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.6.6
- open-webui (PyPI): affected all versions; fixed in 0.6.6
- open-webui (PyPI): affected all versions; fixed in 0.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46719/ (Markdown: https://insights.sbomify.com/CVE-2025-46719/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46719
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46719
- OSV: https://osv.dev/vulnerability/CVE-2025-46719

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46719/
Summaries are generated and may contain mistakes; the official description above is the record.
