# CVE-2025-46720: Keystone has an unintended `isFilterable` bypass that can be used as an oracle to match hidden fields

> Attackers can bypass access controls in Keystone CMS update and delete mutations to infer hidden field values via oracle attacks.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2025
- **Updated:** 5 May 2025
- **Also known as:** GHSA-hg9m-67mm-7pg3

## What is CVE-2025-46720?

CVE-2025-46720 is a low-severity vulnerability in keystonejs keystone, published on 5 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Keystone is a content management system for Node.js. Prior to version 6.5.0, `{field}.isFilterable` access control can be bypassed in `update` and `delete` mutations by adding additional unique filters. These filters can be used as an oracle to probe the existence or value of otherwise unreadable fields. Specifically, when a mutation includes a `where` clause with multiple unique filters (e.g. `id` and `email`), Keystone will attempt to match records even if filtering by the latter fields would normally be rejected by `field.isFilterable` or `list.defaultIsFilterable`. This can allow malicious actors to infer the presence of a particular field value when a filter is successful in returning a result. This affects any project relying on the default or dynamic `isFilterable` behavior (at the list or field level) to prevent external users from using the filtering of fields as a discovery mechanism. While this access control is respected during `findMany` operations, it was not completely enforced during `update` and `delete` mutations when accepting more than one unique `where` values in filters. This has no impact on projects using `isFilterable: false` or `defaultIsFilterable: false` for sensitive fields, or for those who have otherwise omitted filtering by these fields from their GraphQL schema. This issue has been patched in `@keystone-6/core` version 6.5.0. To mitigate this issue in older versions where patching is not a viable pathway, set `isFilterable: false` statically for relevant fields to prevent filtering by them earlier in the access control pipeline (that is, don't use functions); set `{field}.graphql.omit.read: true` for relevant fields, which implicitly removes filtering by these fields from the GraphQL schema; and/or deny `update` and `delete` operations for the relevant lists completely.

Weakness: CWE-203 (Observable Discrepancy), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-46720?

2 open source packages ship an affected version, including @keystone-6/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@keystone-6/core` | npm | All versions | 6.5.0 |
| `@keystone-6/core` | npm | All versions | 6.5.0 |

Products: Keystonejs Keystone.

## How do I fix CVE-2025-46720?

Upgrade @keystone-6/core to 6.5.0 or later.

## Is CVE-2025-46720 being exploited?

There is no known exploitation of CVE-2025-46720 in the wild and no public exploit code.

## Other vulnerabilities in keystonejs keystone

- [CVE-2022-39382](https://insights.sbomify.com/CVE-2022-39382/): NODE_ENV in Keystone defaults to development with esbuild (critical 9.8)
- [CVE-2022-29354](https://insights.sbomify.com/CVE-2022-29354/): File upload in n/a (critical 9.8)
- [CVE-2022-39322](https://insights.sbomify.com/CVE-2022-39322/): @keystone-6/core vulnerable to field-level access-control bypass for multiselect field (critical 9.1)
- [CVE-2017-16570](https://insights.sbomify.com/CVE-2017-16570/): Cross-Site Request Forgery (CSRF) in keystone (high 8.8)
- [CVE-2017-15879](https://insights.sbomify.com/CVE-2017-15879/): Keystone is vulnerable to CSV injection (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46720 and fix it if it is affected.

What it is: CVE-2025-46720 is a low-severity vulnerability in keystonejs keystone, published on 5 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-46720 in the wild and no public exploit code.

Affected packages and fixed versions:
- @keystone-6/core (npm): affected all versions; fixed in 6.5.0
- @keystone-6/core (npm): affected all versions; fixed in 6.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46720/ (Markdown: https://insights.sbomify.com/CVE-2025-46720/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46720
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46720
- OSV: https://osv.dev/vulnerability/CVE-2025-46720

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46720/
Summaries are generated and may contain mistakes; the official description above is the record.
