# CVE-2025-46722: vLLM has a Weakness in MultiModalHasher Image Hashing Implementation

> Attackers can cause hash collisions in vLLM's image hashing, leading to incorrect cache hits and potential data leakage.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2025
- **Updated:** 29 May 2025
- **Also known as:** GHSA-c65p-x677-fgj6, PYSEC-2025-43

## What is CVE-2025-46722?

CVE-2025-46722 is a medium-severity vulnerability in Vllm Vllm, published on 29 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). In versions starting from 0.7.0 to before 0.9.0, in the file vllm/multimodal/hasher.py, the MultiModalHasher class has a security and data integrity issue in its image hashing method. Currently, it serializes PIL.Image.Image objects using only obj.tobytes(), which returns only the raw pixel data, without including metadata such as the image’s shape (width, height, mode). As a result, two images of different sizes (e.g., 30x100 and 100x30) with the same pixel byte sequence could generate the same hash value. This may lead to hash collisions, incorrect cache hits, and even data leakage or security risks. This issue has been patched in version 0.9.0.

Weakness: CWE-1288 (Improper Validation of Consistency within Input), CWE-1023 (Incomplete Comparison with Missing Factors)

## Which versions are affected by CVE-2025-46722?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.9.0 |
| `vllm` | PyPI | From 0.7.0 | 0.9.0 |
| `vllm` | PyPI | From 0.7.0 | 0.9.0 |

Products: Vllm Vllm.

## How do I fix CVE-2025-46722?

Upgrade vllm to 0.9.0 or later.

## Is CVE-2025-46722 being exploited?

There is no known exploitation of CVE-2025-46722 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46722 and fix it if it is affected.

What it is: CVE-2025-46722 is a medium-severity vulnerability in Vllm Vllm, published on 29 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-46722 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.9.0
- vllm (PyPI): affected from 0.7.0; fixed in 0.9.0
- vllm (PyPI): affected from 0.7.0; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46722/ (Markdown: https://insights.sbomify.com/CVE-2025-46722/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46722
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46722
- OSV: https://osv.dev/vulnerability/CVE-2025-46722

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46722/
Summaries are generated and may contain mistakes; the official description above is the record.
