{"answers":{"affected":"2 open source packages ship an affected version, including openvm.","exploited":"There is no known exploitation of CVE-2025-46723 in the wild and no public exploit code.","fix":"Upgrade openvm to 1.1.0 or later.","what":"CVE-2025-46723 is a high-severity vulnerability in openvm-org openvm, published on 2 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-46723 and fix it if it is affected.\n\nWhat it is: CVE-2025-46723 is a high-severity vulnerability in openvm-org openvm, published on 2 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-46723 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openvm (crates.io): affected from 1.0.0; fixed in 1.1.0\n- openvm (crates.io): affected from 1.0.0; fixed in 1.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-46723/ (Markdown: https://insights.sbomify.com/CVE-2025-46723/index.md)","id":"CVE-2025-46723","markdown":"https://insights.sbomify.com/CVE-2025-46723/index.md","name":"CVE-2025-46723","record":{"aliases":["GHSA-jf2r-x3j4-23m7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"zkVM framework","requires_auth":"none","summary":"A malicious prover can exploit an integer overflow in the AUIPC chip to manipulate the program counter, potentially leading to arbitrary code execution or data modification.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-131","name":"Incorrect Calculation of Buffer Size"}],"description":"OpenVM is a performant and modular zkVM framework built for customization and extensibility. In version 1.0.0, OpenVM is vulnerable to overflow through byte decomposition of pc in AUIPC chip. A typo results in the highest limb of pc being range checked to 8-bits instead of 6-bits. This results in the if statement never being triggered because the enumeration gives i=0,1,2, when instead the enumeration should give i=1,2,3, leaving pc_limbs[3] range checked to 8-bits instead of 6-bits. This leads to a vulnerability where the pc_limbs decomposition differs from the true pc, which means a malicious prover can make the destination register take a different value than the AUIPC instruction dictates, by making the decomposition overflow the BabyBear field. This issue has been patched in version 1.1.0.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenVM byte decomposition of pc in AUIPC chip can overflow","id":"CVE-2025-46723","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"integer_overflow","year":"2025"},"n_packages":2,"n_references":5,"next":{"headline":"Langroid has a Code Injection vulnerability in TableChatAgent","id":"CVE-2025-46724"},"packages":[{"ecosystem":"crates.io","fixed":["1.1.0"],"introduced":["1.0.0"],"last_affected":[],"package":"openvm","purl":null,"source":"GHSA-jf2r-x3j4-23m7"},{"ecosystem":"crates.io","fixed":["1.1.0"],"introduced":["1.0.0"],"last_affected":[],"package":"openvm","purl":"pkg:cargo/openvm","source":"GHSA-jf2r-x3j4-23m7"}],"prev":{"headline":"vLLM has a Weakness in MultiModalHasher Image Hashing Implementation","id":"CVE-2025-46722"},"products":["openvm"],"published":"2025-05-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-06","vendors":["openvm-org"]},"summary":"A malicious prover can exploit an integer overflow in the AUIPC chip to manipulate the program counter, potentially leading to arbitrary code execution or data modification.","url":"https://insights.sbomify.com/CVE-2025-46723/"}