# CVE-2025-46723: OpenVM byte decomposition of pc in AUIPC chip can overflow

> A malicious prover can exploit an integer overflow in the AUIPC chip to manipulate the program counter, potentially leading to arbitrary code execution or data modification.

- **Severity:** High 7.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 May 2025
- **Updated:** 6 May 2025
- **Also known as:** GHSA-jf2r-x3j4-23m7

## What is CVE-2025-46723?

CVE-2025-46723 is a high-severity vulnerability in openvm-org openvm, published on 2 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenVM is a performant and modular zkVM framework built for customization and extensibility. In version 1.0.0, OpenVM is vulnerable to overflow through byte decomposition of pc in AUIPC chip. A typo results in the highest limb of pc being range checked to 8-bits instead of 6-bits. This results in the if statement never being triggered because the enumeration gives i=0,1,2, when instead the enumeration should give i=1,2,3, leaving pc_limbs[3] range checked to 8-bits instead of 6-bits. This leads to a vulnerability where the pc_limbs decomposition differs from the true pc, which means a malicious prover can make the destination register take a different value than the AUIPC instruction dictates, by making the decomposition overflow the BabyBear field. This issue has been patched in version 1.1.0.

Weakness: CWE-131 (Incorrect Calculation of Buffer Size)

## Which versions are affected by CVE-2025-46723?

2 open source packages ship an affected version, including openvm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openvm` | crates.io | From 1.0.0 | 1.1.0 |
| `openvm` | crates.io | From 1.0.0 | 1.1.0 |

## How do I fix CVE-2025-46723?

Upgrade openvm to 1.1.0 or later.

## Is CVE-2025-46723 being exploited?

There is no known exploitation of CVE-2025-46723 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46723 and fix it if it is affected.

What it is: CVE-2025-46723 is a high-severity vulnerability in openvm-org openvm, published on 2 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-46723 in the wild and no public exploit code.

Affected packages and fixed versions:
- openvm (crates.io): affected from 1.0.0; fixed in 1.1.0
- openvm (crates.io): affected from 1.0.0; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46723/ (Markdown: https://insights.sbomify.com/CVE-2025-46723/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46723
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46723
- OSV: https://osv.dev/vulnerability/CVE-2025-46723

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46723/
Summaries are generated and may contain mistakes; the official description above is the record.
