{"answers":{"affected":"3 open source packages ship an affected version, including langroid. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46724 exists.","fix":"Upgrade langroid to 0.53.15 or later.","what":"CVE-2025-46724 is a critical code injection vulnerability in langroid, published on 20 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-46724 and fix it if it is affected.\n\nWhat it is: CVE-2025-46724 is a critical code injection vulnerability in langroid, published on 20 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46724 exists.\n\nAffected packages and fixed versions:\n- langroid (PyPI): affected all versions; fixed in 0.53.15\n- langroid (PyPI): affected all versions; fixed in 0.53.15\n- langroid (PyPI): affected all versions; fixed in 0.53.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-46724/ (Markdown: https://insights.sbomify.com/CVE-2025-46724/index.md)","id":"CVE-2025-46724","markdown":"https://insights.sbomify.com/CVE-2025-46724/index.md","name":"CVE-2025-46724","record":{"aliases":["GHSA-jqq5-wc57-f8hj","PYSEC-2026-381"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python LLM framework","requires_auth":"none","summary":"Attackers can execute arbitrary code via untrusted input in TableChatAgent due to unsafe pandas eval usage in Langroid.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"langroid","vendor":"langroid"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Langroid is a Python framework to build large language model (LLM)-powered applications. Prior to version 0.53.15, `TableChatAgent` uses `pandas eval()`. If fed by untrusted user input, like the case of a public-facing LLM application, it may be vulnerable to code injection. Langroid 0.53.15 sanitizes input to `TableChatAgent` by default to tackle the most common attack vectors, and added several warnings about the risky behavior in the project documentation.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Langroid has a Code Injection vulnerability in TableChatAgent","id":"CVE-2025-46724","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Langroid has a Code Injection vulnerability in LanceDocChatAgent through vector_store","id":"CVE-2025-46725"},"packages":[{"ecosystem":"PyPI","fixed":["0.53.15"],"introduced":["0"],"last_affected":[],"package":"langroid","purl":null,"source":"GHSA-jqq5-wc57-f8hj"},{"ecosystem":"PyPI","fixed":["0.53.15"],"introduced":["0"],"last_affected":[],"package":"langroid","purl":"pkg:pypi/langroid","source":"GHSA-jqq5-wc57-f8hj"},{"ecosystem":"PyPI","fixed":["0.53.15"],"introduced":["0"],"last_affected":[],"package":"langroid","purl":"pkg:pypi/langroid","source":"PYSEC-2026-381"}],"prev":{"headline":"OpenVM byte decomposition of pc in AUIPC chip can overflow","id":"CVE-2025-46723"},"products":["langroid"],"published":"2025-05-20","related":[{"cvss_score":9.4,"headline":"Langroid has WAF Bypass Leading to RCE in TableChatAgent","id":"CVE-2026-25481","kev_date_added":null,"published":"2026-02-04"},{"cvss_score":8.1,"headline":"Langroid has a Code Injection vulnerability in LanceDocChatAgent through vector_store","id":"CVE-2025-46725","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":7.8,"headline":"Langroid Vulnerable to XXE Injection via XMLToolMessage","id":"CVE-2025-46726","kev_date_added":null,"published":"2025-05-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-20","vendors":["langroid"]},"summary":"Attackers can execute arbitrary code via untrusted input in TableChatAgent due to unsafe pandas eval usage in Langroid.","url":"https://insights.sbomify.com/CVE-2025-46724/"}