{"answers":{"affected":"3 open source packages ship an affected version, including langroid. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-46725 in the wild and no public exploit code.","fix":"Upgrade langroid to 0.53.15 or later.","what":"CVE-2025-46725 is a high-severity code injection vulnerability in langroid, published on 20 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-46725 and fix it if it is affected.\n\nWhat it is: CVE-2025-46725 is a high-severity code injection vulnerability in langroid, published on 20 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-46725 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- langroid (PyPI): affected all versions; fixed in 0.53.15\n- langroid (PyPI): affected all versions; fixed in 0.53.15\n- langroid (PyPI): affected all versions; fixed in 0.53.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-46725/ (Markdown: https://insights.sbomify.com/CVE-2025-46725/index.md)","id":"CVE-2025-46725","markdown":"https://insights.sbomify.com/CVE-2025-46725/index.md","name":"CVE-2025-46725","record":{"aliases":["GHSA-22c2-9gwg-mj59","PYSEC-2026-1531"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python LLM framework","requires_auth":"none","summary":"Attackers can execute arbitrary code on the host system via malicious input in Langroid's LanceDocChatAgent due to unsafe pandas eval usage.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"langroid","vendor":"langroid"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Langroid is a Python framework to build large language model (LLM)-powered applications. Prior to version 0.53.15, `LanceDocChatAgent` uses pandas eval() through `compute_from_docs()`. As a result, an attacker may be able to make the agent run malicious commands through `QueryPlan.dataframe_calc]`) compromising the host system. Langroid 0.53.15 sanitizes input to the affected function by default to tackle the most common attack vectors, and added several warnings about the risky behavior in the project documentation.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Langroid has a Code Injection vulnerability in LanceDocChatAgent through vector_store","id":"CVE-2025-46725","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Langroid Vulnerable to XXE Injection via XMLToolMessage","id":"CVE-2025-46726"},"packages":[{"ecosystem":"PyPI","fixed":["0.53.15"],"introduced":["0"],"last_affected":[],"package":"langroid","purl":null,"source":"GHSA-22c2-9gwg-mj59"},{"ecosystem":"PyPI","fixed":["0.53.15"],"introduced":["0"],"last_affected":[],"package":"langroid","purl":"pkg:pypi/langroid","source":"GHSA-22c2-9gwg-mj59"},{"ecosystem":"PyPI","fixed":["0.53.15"],"introduced":["0"],"last_affected":[],"package":"langroid","purl":"pkg:pypi/langroid","source":"PYSEC-2026-1531"}],"prev":{"headline":"Langroid has a Code Injection vulnerability in TableChatAgent","id":"CVE-2025-46724"},"products":["langroid"],"published":"2025-05-20","related":[{"cvss_score":9.8,"headline":"Langroid has a Code Injection vulnerability in TableChatAgent","id":"CVE-2025-46724","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.4,"headline":"Langroid has WAF Bypass Leading to RCE in TableChatAgent","id":"CVE-2026-25481","kev_date_added":null,"published":"2026-02-04"},{"cvss_score":7.8,"headline":"Langroid Vulnerable to XXE Injection via XMLToolMessage","id":"CVE-2025-46726","kev_date_added":null,"published":"2025-05-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-20","vendors":["langroid"]},"summary":"Attackers can execute arbitrary code on the host system via malicious input in Langroid's LanceDocChatAgent due to unsafe pandas eval usage.","url":"https://insights.sbomify.com/CVE-2025-46725/"}