# CVE-2025-46725: Langroid has a Code Injection vulnerability in LanceDocChatAgent through vector_store

> Attackers can execute arbitrary code on the host system via malicious input in Langroid's LanceDocChatAgent due to unsafe pandas eval usage.

- **Severity:** High 8.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 May 2025
- **Updated:** 20 May 2025
- **Also known as:** GHSA-22c2-9gwg-mj59, PYSEC-2026-1531

## What is CVE-2025-46725?

CVE-2025-46725 is a high-severity code injection vulnerability in langroid, published on 20 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Langroid is a Python framework to build large language model (LLM)-powered applications. Prior to version 0.53.15, `LanceDocChatAgent` uses pandas eval() through `compute_from_docs()`. As a result, an attacker may be able to make the agent run malicious commands through `QueryPlan.dataframe_calc]`) compromising the host system. Langroid 0.53.15 sanitizes input to the affected function by default to tackle the most common attack vectors, and added several warnings about the risky behavior in the project documentation.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-46725?

3 open source packages ship an affected version, including langroid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langroid` | PyPI | All versions | 0.53.15 |
| `langroid` | PyPI | All versions | 0.53.15 |
| `langroid` | PyPI | All versions | 0.53.15 |

Products: Langroid Langroid.

## How do I fix CVE-2025-46725?

Upgrade langroid to 0.53.15 or later.

## Is CVE-2025-46725 being exploited?

There is no known exploitation of CVE-2025-46725 in the wild and no public exploit code.

## Other vulnerabilities in langroid

- [CVE-2025-46724](https://insights.sbomify.com/CVE-2025-46724/): Langroid has a Code Injection vulnerability in TableChatAgent (critical 9.8)
- [CVE-2026-25481](https://insights.sbomify.com/CVE-2026-25481/): Langroid has WAF Bypass Leading to RCE in TableChatAgent (critical 9.4)
- [CVE-2025-46726](https://insights.sbomify.com/CVE-2025-46726/): Langroid Vulnerable to XXE Injection via XMLToolMessage (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46725 and fix it if it is affected.

What it is: CVE-2025-46725 is a high-severity code injection vulnerability in langroid, published on 20 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-46725 in the wild and no public exploit code.

Affected packages and fixed versions:
- langroid (PyPI): affected all versions; fixed in 0.53.15
- langroid (PyPI): affected all versions; fixed in 0.53.15
- langroid (PyPI): affected all versions; fixed in 0.53.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46725/ (Markdown: https://insights.sbomify.com/CVE-2025-46725/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46725
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46725
- OSV: https://osv.dev/vulnerability/CVE-2025-46725

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46725/
Summaries are generated and may contain mistakes; the official description above is the record.
