# CVE-2025-46731: Craft CMS Contains a Potential Remote Code Execution Vulnerability via Twig SSTI

> Administrators with specific settings enabled can execute arbitrary code via Twig Server-Side Template Injection in Craft CMS.

- **Severity:** High 7.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2025
- **Updated:** 5 May 2025
- **Also known as:** GHSA-7c58-g782-9j38

## What is CVE-2025-46731?

CVE-2025-46731 is a high-severity code injection vulnerability in Craftcms Craft Cms, published on 5 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Craft is a content management system. Versions of Craft CMS on the 4.x branch prior to 4.14.13 and on the 5.x branch prior to 5.6.16 contains a potential remote code execution vulnerability via Twig SSTI. One must have administrator access and `ALLOW_ADMIN_CHANGES` must be enabled for this to work. Users should update to the patched versions 4.14.13 or 5.6.15 to mitigate the issue.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2025-46731?

4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.14.13 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.14.13 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.6.15 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.6.15 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2025-46731?

Upgrade craftcms/cms to a fixed version for your release line: 4.14.13 or 5.6.15.

## Is CVE-2025-46731 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46731 exists.

Public exploit code:

- https://github.com/singetu0096/CVE-2025-46731 (github_poc): https://github.com/singetu0096/CVE-2025-46731

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46731 and fix it if it is affected.

What it is: CVE-2025-46731 is a high-severity code injection vulnerability in Craftcms Craft Cms, published on 5 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46731 exists.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.14.13
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.14.13
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.6.15
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.6.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46731/ (Markdown: https://insights.sbomify.com/CVE-2025-46731/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46731
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46731
- OSV: https://osv.dev/vulnerability/CVE-2025-46731

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46731/
Summaries are generated and may contain mistakes; the official description above is the record.
