{"answers":{"affected":"2 open source packages ship an affected version, including league/commonmark.","exploited":"There is no known exploitation of CVE-2025-46734 in the wild and no public exploit code.","fix":"Upgrade league/commonmark to 2.7.0 or later.","what":"CVE-2025-46734 is a medium-severity cross-site scripting vulnerability in thephpleague commonmark, published on 5 May 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-46734 and fix it if it is affected.\n\nWhat it is: CVE-2025-46734 is a medium-severity cross-site scripting vulnerability in thephpleague commonmark, published on 5 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-46734 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- league/commonmark (Packagist): affected from 1.5.0; fixed in 2.7.0\n- league/commonmark (Packagist): affected from 1.5.0; fixed in 2.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-46734/ (Markdown: https://insights.sbomify.com/CVE-2025-46734/index.md)","id":"CVE-2025-46734","markdown":"https://insights.sbomify.com/CVE-2025-46734/index.md","name":"CVE-2025-46734","record":{"aliases":["CLSA-2026-1771980771","DEBIAN-CVE-2025-46734","GHSA-3527-qv2q-pfvx","UBUNTU-CVE-2025-46734"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP Markdown parser","requires_auth":"low_privilege","summary":"Remote attackers can inject malicious JavaScript via Markdown attributes in the league/commonmark library when the Attributes extension is enabled.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"league/commonmark is a PHP Markdown parser. A cross-site scripting (XSS) vulnerability in the Attributes extension of the league/commonmark library (versions 1.5.0 through 2.6.x) allows remote attackers to insert malicious JavaScript calls into HTML. The league/commonmark library provides configuration options such as `html_input: 'strip'` and `allow_unsafe_links: false` to mitigate cross-site scripting (XSS) attacks by stripping raw HTML and disallowing unsafe links. However, when the Attributes Extension is enabled, it introduces a way for users to inject arbitrary HTML attributes into elements via Markdown syntax using curly braces. Version 2.7.0 contains three changes to prevent this XSS attack vector: All attributes starting with `on` are considered unsafe and blocked by default; support for an explicit allowlist of allowed HTML attributes; and manually-added `href` and `src` attributes now respect the existing `allow_unsafe_links` configuration option. If upgrading is not feasible, please consider disabling the `AttributesExtension` for untrusted users and/or filtering the rendered HTML through a library like HTMLPurifier.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"league/commonmark Cross-site Scripting vulnerability in Attributes extension","id":"CVE-2025-46734","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Terraform WinDNS Provider improperly sanitizes input variables in `windns_record`","id":"CVE-2025-46735"},"packages":[{"ecosystem":"Packagist","fixed":["2.7.0"],"introduced":["1.5.0"],"last_affected":[],"package":"league/commonmark","purl":null,"source":"GHSA-3527-qv2q-pfvx"},{"ecosystem":"Packagist","fixed":["2.7.0"],"introduced":["1.5.0"],"last_affected":[],"package":"league/commonmark","purl":"pkg:composer/league/commonmark","source":"GHSA-3527-qv2q-pfvx"}],"prev":{"headline":"REE userspace code can panic TAs, leading to fTPM PCR reset and data disclosure","id":"CVE-2025-46733"},"products":["commonmark"],"published":"2025-05-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-06","vendors":["thephpleague"]},"summary":"Remote attackers can inject malicious JavaScript via Markdown attributes in the league/commonmark library when the Attributes extension is enabled.","url":"https://insights.sbomify.com/CVE-2025-46734/"}