{"answers":{"affected":"2 open source packages ship an affected version, including trix.","exploited":"There is no known exploitation of CVE-2025-46812 in the wild and no public exploit code.","fix":"Upgrade trix to 2.1.15 or later.","what":"CVE-2025-46812 is a low-severity cross-site scripting vulnerability in basecamp trix, published on 8 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-46812 and fix it if it is affected.\n\nWhat it is: CVE-2025-46812 is a low-severity cross-site scripting vulnerability in basecamp trix, published on 8 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-46812 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- trix (npm): affected all versions; fixed in 2.1.15\n- trix (npm): affected all versions; fixed in 2.1.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-46812/ (Markdown: https://insights.sbomify.com/CVE-2025-46812/index.md)","id":"CVE-2025-46812","markdown":"https://insights.sbomify.com/CVE-2025-46812/index.md","name":"CVE-2025-46812","record":{"aliases":["GHSA-mcrw-746g-9q8h"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Trix rich text editor","requires_auth":"none","summary":"An attacker can execute arbitrary JavaScript in a user's session by tricking them into pasting malicious code into the Trix editor.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Trix is a what-you-see-is-what-you-get rich text editor for everyday writing. Versions prior to 2.1.15 are vulnerable to XSS attacks when pasting malicious code. An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. This issue has been patched in version 2.1.15.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Trix vulnerable to Cross-site Scripting on copy \u0026 paste","id":"CVE-2025-46812","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Private data leak on login-required Discourse sites","id":"CVE-2025-46813"},"packages":[{"ecosystem":"npm","fixed":["2.1.15"],"introduced":["0"],"last_affected":[],"package":"trix","purl":null,"source":"GHSA-mcrw-746g-9q8h"},{"ecosystem":"npm","fixed":["2.1.15"],"introduced":["0"],"last_affected":[],"package":"trix","purl":"pkg:npm/trix","source":"GHSA-mcrw-746g-9q8h"}],"prev":{"headline":"SUSE Multi Linux Manager allows code execution via unprotected websocket endpoint","id":"CVE-2025-46811"},"products":["trix"],"published":"2025-05-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-08","vendors":["basecamp"]},"summary":"An attacker can execute arbitrary JavaScript in a user's session by tricking them into pasting malicious code into the Trix editor.","url":"https://insights.sbomify.com/CVE-2025-46812/"}