# CVE-2025-46812: Trix vulnerable to Cross-site Scripting on copy & paste

> An attacker can execute arbitrary JavaScript in a user's session by tricking them into pasting malicious code into the Trix editor.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 May 2025
- **Updated:** 8 May 2025
- **Also known as:** GHSA-mcrw-746g-9q8h

## What is CVE-2025-46812?

CVE-2025-46812 is a low-severity cross-site scripting vulnerability in basecamp trix, published on 8 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Trix is a what-you-see-is-what-you-get rich text editor for everyday writing. Versions prior to 2.1.15 are vulnerable to XSS attacks when pasting malicious code. An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. This issue has been patched in version 2.1.15.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-46812?

2 open source packages ship an affected version, including trix.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trix` | npm | All versions | 2.1.15 |
| `trix` | npm | All versions | 2.1.15 |

## How do I fix CVE-2025-46812?

Upgrade trix to 2.1.15 or later.

## Is CVE-2025-46812 being exploited?

There is no known exploitation of CVE-2025-46812 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46812 and fix it if it is affected.

What it is: CVE-2025-46812 is a low-severity cross-site scripting vulnerability in basecamp trix, published on 8 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-46812 in the wild and no public exploit code.

Affected packages and fixed versions:
- trix (npm): affected all versions; fixed in 2.1.15
- trix (npm): affected all versions; fixed in 2.1.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46812/ (Markdown: https://insights.sbomify.com/CVE-2025-46812/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46812
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46812
- OSV: https://osv.dev/vulnerability/CVE-2025-46812

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46812/
Summaries are generated and may contain mistakes; the official description above is the record.
