{"answers":{"affected":"1 open source package ship an affected version, including fastapi-guard. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46814 exists.","fix":"Upgrade fastapi-guard to 2.0.0 or later.","what":"CVE-2025-46814 is a low-severity vulnerability in rennf93 fastapi-guard, published on 6 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-46814 and fix it if it is affected.\n\nWhat it is: CVE-2025-46814 is a low-severity vulnerability in rennf93 fastapi-guard, published on 6 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46814 exists.\n\nAffected packages and fixed versions:\n- fastapi-guard (PyPI): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-46814/ (Markdown: https://insights.sbomify.com/CVE-2025-46814/index.md)","id":"CVE-2025-46814","markdown":"https://insights.sbomify.com/CVE-2025-46814/index.md","name":"CVE-2025-46814","record":{"aliases":["GHSA-77q8-qmj7-x7pp","PYSEC-2025-242"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"FastAPI security library","requires_auth":"none","summary":"Attackers can bypass IP-based access controls and impersonate clients by manipulating the X-Forwarded-For header in FastAPI Guard.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fastapi_guard","vendor":"fastapi-guard"}],"cvss":{"score":3.4,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"FastAPI Guard is a security library for FastAPI that provides middleware to control IPs, log requests, and detect penetration attempts. An HTTP header injection vulnerability has been identified in versions prior to 2.0.0. By manipulating the X-Forwarded-For header, an attacker can potentially inject arbitrary IP addresses into the request. This vulnerability can allow attackers to bypass IP-based access controls, mislead logging systems, and impersonate trusted clients. It is especially impactful when the application relies on the X-Forwarded-For header for IP-based authorization or authentication. Users should upgrade to FastAPI Guard version 2.0.0 to receive a fix.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"FastAPI Guard Remote Header Injection via X-Forwarded-For Manipulation","id":"CVE-2025-46814","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":1,"n_references":2,"next":{"headline":"ZITADEL Allows IdP Intent Token Reuse","id":"CVE-2025-46815"},"packages":[{"ecosystem":"PyPI","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"fastapi-guard","purl":"pkg:pypi/fastapi-guard","source":"PYSEC-2025-242"}],"prev":{"headline":"Private data leak on login-required Discourse sites","id":"CVE-2025-46813"},"products":["fastapi-guard"],"published":"2025-05-06","related":[{"cvss_score":7.8,"headline":"fastapi-guard patch contains bypassable RegEx","id":"CVE-2025-54365","kev_date_added":null,"published":"2025-07-23"},{"cvss_score":6.9,"headline":"ReDoS in fastapi-guard's penetration attempts detector","id":"CVE-2025-53539","kev_date_added":null,"published":"2025-07-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-06","vendors":["rennf93"]},"summary":"Attackers can bypass IP-based access controls and impersonate clients by manipulating the X-Forwarded-For header in FastAPI Guard.","url":"https://insights.sbomify.com/CVE-2025-46814/"}