# CVE-2025-46814: FastAPI Guard Remote Header Injection via X-Forwarded-For Manipulation

> Attackers can bypass IP-based access controls and impersonate clients by manipulating the X-Forwarded-For header in FastAPI Guard.

- **Severity:** Low 3.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 May 2025
- **Updated:** 6 May 2025
- **Also known as:** GHSA-77q8-qmj7-x7pp, PYSEC-2025-242

## What is CVE-2025-46814?

CVE-2025-46814 is a low-severity vulnerability in rennf93 fastapi-guard, published on 6 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

FastAPI Guard is a security library for FastAPI that provides middleware to control IPs, log requests, and detect penetration attempts. An HTTP header injection vulnerability has been identified in versions prior to 2.0.0. By manipulating the X-Forwarded-For header, an attacker can potentially inject arbitrary IP addresses into the request. This vulnerability can allow attackers to bypass IP-based access controls, mislead logging systems, and impersonate trusted clients. It is especially impactful when the application relies on the X-Forwarded-For header for IP-based authorization or authentication. Users should upgrade to FastAPI Guard version 2.0.0 to receive a fix.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2025-46814?

1 open source package ship an affected version, including fastapi-guard. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastapi-guard` | PyPI | All versions | 2.0.0 |

Products: Fastapi-Guard Fastapi Guard.

## How do I fix CVE-2025-46814?

Upgrade fastapi-guard to 2.0.0 or later.

## Is CVE-2025-46814 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46814 exists.

## Other vulnerabilities in rennf93 fastapi-guard

- [CVE-2025-54365](https://insights.sbomify.com/CVE-2025-54365/): fastapi-guard patch contains bypassable RegEx (high 7.8)
- [CVE-2025-53539](https://insights.sbomify.com/CVE-2025-53539/): ReDoS in fastapi-guard's penetration attempts detector (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46814 and fix it if it is affected.

What it is: CVE-2025-46814 is a low-severity vulnerability in rennf93 fastapi-guard, published on 6 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46814 exists.

Affected packages and fixed versions:
- fastapi-guard (PyPI): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46814/ (Markdown: https://insights.sbomify.com/CVE-2025-46814/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46814
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46814
- OSV: https://osv.dev/vulnerability/CVE-2025-46814

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46814/
Summaries are generated and may contain mistakes; the official description above is the record.
