CVE-2025-46815 ZITADEL Allows IdP Intent Token Reuse
Attackers can reuse IdP intent tokens to authenticate as users, potentially leading to account takeover if MFA is not enforced.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-46815?
CVE-2025-46815 is a high-severity authentication bypass vulnerability in zitadel, published on 6 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The identity infrastructure software ZITADEL offers developers the ability to manage user sessions using the Session API. This API enables the use of IdPs for authentication, known as idp intents. Following a successful idp intent, the client receives an id and token on a predefined URI. These id and token can then be used to authenticate the user or their session. However, prior to versions 3.0.0, 2.71.9, and 2.70.10, it was possible to exploit this feature by repeatedly using intents. This allowed an attacker with access to the application’s URI to retrieve the id and token, enabling them to authenticate on behalf of the user. It's important to note that the use of additional factors (MFA) prevents a complete authentication process and, consequently, access to the ZITADEL API. Versions 3.0.0, 2.71.9, and 2.70.10 contain a fix for the issue. No known workarounds other than upgrading are available.
Which versions are affected by CVE-2025-46815?
7 open source packages ship an affected version, including github.com/zitadel/zitadel. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/zitadel/zitadel Go | All versions | None |
github.com/zitadel/zitadel Go | All versions | 2.70.10 |
github.com/zitadel/zitadel Go | All versions | 2.70.10 |
github.com/zitadel/zitadel Go | From 2.71.0 | 2.71.9 |
github.com/zitadel/zitadel Go | From 2.71.0 | 2.71.9 |
github.com/zitadel/zitadel Go | From 3.0.0-rc.1 | 3.0.0 |
1 more packages
github.com/zitadel/zitadel Go | From 3.0.0-rc.1 | 3.0.0 |
Products include Zitadel Zitadel.
How do I fix CVE-2025-46815?
Upgrade github.com/zitadel/zitadel to a fixed version for your release line: 2.70.10, 2.71.9 or 3.0.0.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-46815 being exploited?
There is no known exploitation of CVE-2025-46815 in the wild and no public exploit code.
Other vulnerabilities in zitadel
- CVE-2026-29191 ZITADEL: 1-Click Account Takeover via XSS in /saml-post Endpoint
- CVE-2025-67494 ZITADEL Vulnerable to Unauthenticated Full-Read SSRF via V2 Login
- CVE-2025-27507 IDOR Vulnerabilities in ZITADEL's Admin API that Primarily Impact LDAP Configurations
- CVE-2025-64103 Zitadel Bypass Second Authentication Factor
- CVE-2025-31123 Zitadel Expired JWT Keys Usable for Authorization Grants
Sources
Also known as GHSA-g4r8-mp7g-85fq, GO-2025-3671.