# CVE-2025-46815: ZITADEL Allows IdP Intent Token Reuse

> Attackers can reuse IdP intent tokens to authenticate as users, potentially leading to account takeover if MFA is not enforced.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 May 2025
- **Updated:** 6 May 2025
- **Also known as:** GHSA-g4r8-mp7g-85fq, GO-2025-3671

## What is CVE-2025-46815?

CVE-2025-46815 is a high-severity authentication bypass vulnerability in zitadel, published on 6 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The identity infrastructure software ZITADEL offers developers the ability to manage user sessions using the Session API. This API enables the use of IdPs for authentication, known as idp intents. Following a successful idp intent, the client receives an id and token on a predefined URI. These id and token can then be used to authenticate the user or their session. However, prior to versions 3.0.0, 2.71.9, and 2.70.10, it was possible to exploit this feature by repeatedly using intents. This allowed an attacker with access to the application’s URI to retrieve the id and token, enabling them to authenticate on behalf of the user. It's important to note that the use of additional factors (MFA) prevents a complete authentication process and, consequently, access to the ZITADEL API. Versions 3.0.0, 2.71.9, and 2.70.10 contain a fix for the issue. No known workarounds other than upgrading are available.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration), CWE-384 (Session Fixation), CWE-294 (Authentication Bypass by Capture-replay)

## Which versions are affected by CVE-2025-46815?

7 open source packages ship an affected version, including github.com/zitadel/zitadel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/zitadel/zitadel` | Go | All versions | None |
| `github.com/zitadel/zitadel` | Go | All versions | 2.70.10 |
| `github.com/zitadel/zitadel` | Go | All versions | 2.70.10 |
| `github.com/zitadel/zitadel` | Go | From 2.71.0 | 2.71.9 |
| `github.com/zitadel/zitadel` | Go | From 2.71.0 | 2.71.9 |
| `github.com/zitadel/zitadel` | Go | From 3.0.0-rc.1 | 3.0.0 |
| `github.com/zitadel/zitadel` | Go | From 3.0.0-rc.1 | 3.0.0 |

Products: Zitadel Zitadel.

## How do I fix CVE-2025-46815?

Upgrade github.com/zitadel/zitadel to a fixed version for your release line: 2.70.10, 2.71.9 or 3.0.0.

## Is CVE-2025-46815 being exploited?

There is no known exploitation of CVE-2025-46815 in the wild and no public exploit code.

## Other vulnerabilities in zitadel

- [CVE-2026-29191](https://insights.sbomify.com/CVE-2026-29191/): ZITADEL: 1-Click Account Takeover via XSS in /saml-post Endpoint (critical 9.3)
- [CVE-2025-67494](https://insights.sbomify.com/CVE-2025-67494/): ZITADEL Vulnerable to Unauthenticated Full-Read SSRF via V2 Login (critical 9.3)
- [CVE-2025-27507](https://insights.sbomify.com/CVE-2025-27507/): IDOR Vulnerabilities in ZITADEL's Admin API that Primarily Impact LDAP Configurations (critical 9.0)
- [CVE-2025-64103](https://insights.sbomify.com/CVE-2025-64103/): Zitadel Bypass Second Authentication Factor (high 8.7)
- [CVE-2025-31123](https://insights.sbomify.com/CVE-2025-31123/): Zitadel Expired JWT Keys Usable for Authorization Grants (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46815 and fix it if it is affected.

What it is: CVE-2025-46815 is a high-severity authentication bypass vulnerability in zitadel, published on 6 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-46815 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/zitadel/zitadel (Go): affected all versions; no fix listed
- github.com/zitadel/zitadel (Go): affected all versions; fixed in 2.70.10
- github.com/zitadel/zitadel (Go): affected all versions; fixed in 2.70.10
- github.com/zitadel/zitadel (Go): affected from 2.71.0; fixed in 2.71.9
- github.com/zitadel/zitadel (Go): affected from 2.71.0; fixed in 2.71.9
- github.com/zitadel/zitadel (Go): affected from 3.0.0-rc.1; fixed in 3.0.0
- github.com/zitadel/zitadel (Go): affected from 3.0.0-rc.1; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46815/ (Markdown: https://insights.sbomify.com/CVE-2025-46815/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46815
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46815
- OSV: https://osv.dev/vulnerability/CVE-2025-46815

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46815/
Summaries are generated and may contain mistakes; the official description above is the record.
