# CVE-2025-46816: goshs route not protected, allows command execution

> Attackers can execute arbitrary commands on goshs servers via websockets when the server is run without specific arguments, bypassing intended restrictions.

- **Severity:** Critical 9.4 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2025
- **Updated:** 6 May 2025
- **Also known as:** GHSA-rwj2-w85g-5cmm, GO-2025-3672

## What is CVE-2025-46816?

CVE-2025-46816 is a critical command injection vulnerability in patrickhener goshs, published on 6 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

goshs is a SimpleHTTPServer written in Go. Starting in version 0.3.4 and prior to version 1.0.5, running goshs without arguments makes it possible for anyone to execute commands on the server. The function `dispatchReadPump` does not checks the option cli `-c`, thus allowing anyone to execute arbitrary command through the use of websockets. Version 1.0.5 fixes the issue.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-46816?

3 open source packages ship an affected version, including github.com/patrickhener/goshs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/patrickhener/goshs` | Go | From 0.3.4 | 1.0.5 |
| `github.com/patrickhener/goshs` | Go | From 0.3.4 | 1.0.5 |
| `github.com/patrickhener/goshs` | Go | From 0.3.4 | 1.0.5 |

## How do I fix CVE-2025-46816?

Upgrade github.com/patrickhener/goshs to 1.0.5 or later.

## Is CVE-2025-46816 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46816 exists.

Public exploit code:

- POC for exploit of goshs (github_poc): https://github.com/Guilhem7/CVE-2025-46816

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46816 and fix it if it is affected.

What it is: CVE-2025-46816 is a critical command injection vulnerability in patrickhener goshs, published on 6 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46816 exists.

Affected packages and fixed versions:
- github.com/patrickhener/goshs (Go): affected from 0.3.4; fixed in 1.0.5
- github.com/patrickhener/goshs (Go): affected from 0.3.4; fixed in 1.0.5
- github.com/patrickhener/goshs (Go): affected from 0.3.4; fixed in 1.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46816/ (Markdown: https://insights.sbomify.com/CVE-2025-46816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46816
- OSV: https://osv.dev/vulnerability/CVE-2025-46816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46816/
Summaries are generated and may contain mistakes; the official description above is the record.
