# CVE-2025-46817: Lua library commands may lead to integer overflow and potential RCE

> An authenticated attacker can exploit an integer overflow in Redis Lua scripting to achieve remote code execution.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Oct 2025
- **Updated:** 3 Oct 2025
- **Also known as:** ALPINE-CVE-2025-46817, AZL-68238, AZL-68661, AZL-68664, BELL-CVE-2025-46817, BIT-keydb-2025-46817, BIT-redis-2025-46817, BIT-valkey-2025-46817, CLEANSTART-2026-QE34516, CLSA-2025-1762244363, DEBIAN-CVE-2025-46817, GHSA-m8fj-85cg-7vhp, MINI-45q4-9r5w-373h, MINI-8cc3-wh4g-q7cj, MINI-j375-29rm-gv55, MINI-jprc-85wp-jvx9, MINI-x3jm-rvcf-g43c, UBUNTU-CVE-2025-46817

## What is CVE-2025-46817?

CVE-2025-46817 is a high-severity vulnerability in redis, published on 3 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2025-46817?

3 open source packages ship an affected version, including redis, keydb and valkey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `redis` | Bitnami | All versions | 6.2.20, 7.2.11, 7.4.6, 8.0.4, 8.2.2 |
| `keydb` | Bitnami | All versions | 6.2.20, 7.2.11, 7.4.6, 8.0.4, 8.2.2 |
| `valkey` | Bitnami | All versions | 7.2.11, 8.0.6, 8.1.4 |

Products: Redis Redis.

## How do I fix CVE-2025-46817?

Upgrade redis to a fixed version for your release line: 6.2.20, 7.2.11, 7.4.6 or 8.0.4.

## Is CVE-2025-46817 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46817 exists.

Public exploit code:

- CVE-2025-46817 – Redis Lua unpack Integer Overflow (Potential RCE) (github_poc): https://github.com/dwisiswant0/CVE-2025-46817
- https://github.com/slayerkkkk/CVE-2025-46817-PoC (github_poc): https://github.com/slayerkkkk/CVE-2025-46817-PoC
- Redis < 8.2.1 lua script - Integer Overflow (nuclei)

## Other vulnerabilities in redis

- [CVE-2022-0543](https://insights.sbomify.com/CVE-2022-0543/): Debian-specific Redis Server Lua Sandbox Escape (critical 10.0, exploited in the wild)
- [CVE-2026-23479](https://insights.sbomify.com/CVE-2026-23479/): redis-server use-after-free in unblock client flow may allow remote code execution (high 7.7)
- [CVE-2026-25243](https://insights.sbomify.com/CVE-2026-25243/): redis-server RESTORE invalid memory access may allow remote code execution (high 7.7)
- [CVE-2025-62507](https://insights.sbomify.com/CVE-2025-62507/): Redis: Bug in XACKDEL may lead to stack overflow and potential RCE (high 7.7)
- [CVE-2025-48367](https://insights.sbomify.com/CVE-2025-48367/): Redis DoS Vulnerability due to bad connection error handling (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46817 and fix it if it is affected.

What it is: CVE-2025-46817 is a high-severity vulnerability in redis, published on 3 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46817 exists.

Affected packages and fixed versions:
- redis (Bitnami): affected all versions; fixed in 6.2.20, 7.2.11, 7.4.6, 8.0.4, 8.2.2
- keydb (Bitnami): affected all versions; fixed in 6.2.20, 7.2.11, 7.4.6, 8.0.4, 8.2.2
- valkey (Bitnami): affected all versions; fixed in 7.2.11, 8.0.6, 8.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46817/ (Markdown: https://insights.sbomify.com/CVE-2025-46817/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46817
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46817
- OSV: https://osv.dev/vulnerability/CVE-2025-46817

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46817/
Summaries are generated and may contain mistakes; the official description above is the record.
