# CVE-2025-46818: Redis: Authenticated users can execute LUA scripts as a different user

> Authenticated users can execute arbitrary Lua code in another user's context, enabling privilege escalation and code execution in Redis.

- **Severity:** Medium 6.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Oct 2025
- **Updated:** 3 Oct 2025
- **Also known as:** ALPINE-CVE-2025-46818, AZL-68241, AZL-68285, BELL-CVE-2025-46818, BIT-keydb-2025-46818, BIT-redis-2025-46818, BIT-valkey-2025-46818, CLEANSTART-2026-CD34884, DEBIAN-CVE-2025-46818, GHSA-qrv7-wcrx-q5jp, MINI-232f-h99x-hmrj, MINI-2vjc-vch9-pr9p, MINI-fmvr-gp7g-j7m6, MINI-vxc6-43h2-h6m2, MINI-w7vg-g9rr-gm44, UBUNTU-CVE-2025-46818

## What is CVE-2025-46818?

CVE-2025-46818 is a medium-severity code injection vulnerability in redis, published on 3 Oct 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to manipulate different LUA objects and potentially run their own code in the context of another user. The problem exists in all versions of Redis with LUA scripting. This issue is fixed in version 8.2.2. A workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing LUA scripts. This can be done using ACL to block a script by restricting both the EVAL and FUNCTION command families.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-46818?

3 open source packages ship an affected version, including redis, keydb and valkey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `redis` | Bitnami | All versions | 6.2.20, 7.2.11, 7.4.6, 8.0.4, 8.2.2 |
| `keydb` | Bitnami | All versions | 6.2.20, 7.2.11, 7.4.6, 8.0.4, 8.2.2 |
| `valkey` | Bitnami | All versions | 7.2.11, 8.0.6, 8.1.4 |

Products: Redis Redis.

## How do I fix CVE-2025-46818?

Upgrade redis to a fixed version for your release line: 6.2.20, 7.2.11, 7.4.6 or 8.0.4.

## Is CVE-2025-46818 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46818 exists.

Public exploit code:

- CVE-2025-46818 – Redis Lua Sandbox Cross-User Escape (github_poc): https://github.com/dwisiswant0/CVE-2025-46818
- Redis Lua Sandbox < 8.2.2 - Cross-User Escape (nuclei)

## Other vulnerabilities in redis

- [CVE-2022-0543](https://insights.sbomify.com/CVE-2022-0543/): Debian-specific Redis Server Lua Sandbox Escape (critical 10.0, exploited in the wild)
- [CVE-2026-23479](https://insights.sbomify.com/CVE-2026-23479/): redis-server use-after-free in unblock client flow may allow remote code execution (high 7.7)
- [CVE-2026-25243](https://insights.sbomify.com/CVE-2026-25243/): redis-server RESTORE invalid memory access may allow remote code execution (high 7.7)
- [CVE-2025-62507](https://insights.sbomify.com/CVE-2025-62507/): Redis: Bug in XACKDEL may lead to stack overflow and potential RCE (high 7.7)
- [CVE-2025-48367](https://insights.sbomify.com/CVE-2025-48367/): Redis DoS Vulnerability due to bad connection error handling (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46818 and fix it if it is affected.

What it is: CVE-2025-46818 is a medium-severity code injection vulnerability in redis, published on 3 Oct 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46818 exists.

Affected packages and fixed versions:
- redis (Bitnami): affected all versions; fixed in 6.2.20, 7.2.11, 7.4.6, 8.0.4, 8.2.2
- keydb (Bitnami): affected all versions; fixed in 6.2.20, 7.2.11, 7.4.6, 8.0.4, 8.2.2
- valkey (Bitnami): affected all versions; fixed in 7.2.11, 8.0.6, 8.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46818/ (Markdown: https://insights.sbomify.com/CVE-2025-46818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46818
- OSV: https://osv.dev/vulnerability/CVE-2025-46818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46818/
Summaries are generated and may contain mistakes; the official description above is the record.
