CVE-2025-46821 Envoy vulnerable to bypass of RBAC uri_template permission
Attackers can bypass RBAC rules in Envoy by using asterisks in URI paths, requiring specific RBAC configurations to exploit.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-46821?
CVE-2025-46821 is a medium-severity vulnerability in Envoyproxy Envoy, published on 7 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Envoy is a cloud-native edge/middle/service proxy. Prior to versions 1.34.1, 1.33.3, 1.32.6, and 1.31.8, Envoy's URI template matcher incorrectly excludes the `*` character from a set of valid characters in the URI path. As a result URI path containing the `*` character will not match a URI template expressions. This can result in bypass of RBAC rules when configured using the `uri_template` permissions. This vulnerability is fixed in Envoy versions v1.34.1, v1.33.3, v1.32.6, v1.31.8. As a workaround, configure additional RBAC permissions using `url_path` with `safe_regex` expression.
Weakness: CWE-186
Which versions are affected by CVE-2025-46821?
1 open source package ship an affected version, including envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
envoy Bitnami | All versions | 1.31.8, 1.32.6, 1.33.3, 1.34.1 |
Products include Envoyproxy Envoy.
How do I fix CVE-2025-46821?
Upgrade envoy to a fixed version for your release line: 1.31.8, 1.32.6, 1.33.3 or 1.34.1.
Is CVE-2025-46821 being exploited?
There is no known exploitation of CVE-2025-46821 in the wild and no public exploit code.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2025-46821, GHSA-c7cm-838g-6g67.