# CVE-2025-46821: Envoy vulnerable to bypass of RBAC uri_template permission

> Attackers can bypass RBAC rules in Envoy by using asterisks in URI paths, requiring specific RBAC configurations to exploit.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2025
- **Updated:** 8 May 2025
- **Also known as:** BIT-envoy-2025-46821, GHSA-c7cm-838g-6g67

## What is CVE-2025-46821?

CVE-2025-46821 is a medium-severity vulnerability in Envoyproxy Envoy, published on 7 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy is a cloud-native edge/middle/service proxy. Prior to versions 1.34.1, 1.33.3, 1.32.6, and 1.31.8, Envoy's URI template matcher incorrectly excludes the `*` character from a set of valid characters in the URI path. As a result URI path containing the `*` character will not match a URI template expressions. This can result in bypass of RBAC rules when configured using the `uri_template` permissions. This vulnerability is fixed in Envoy versions v1.34.1, v1.33.3, v1.32.6, v1.31.8. As a workaround, configure additional RBAC permissions using `url_path` with `safe_regex` expression.

Weakness: CWE-186 (Overly Restrictive Regular Expression)

## Which versions are affected by CVE-2025-46821?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | All versions | 1.31.8, 1.32.6, 1.33.3, 1.34.1 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2025-46821?

Upgrade envoy to a fixed version for your release line: 1.31.8, 1.32.6, 1.33.3 or 1.34.1.

## Is CVE-2025-46821 being exploited?

There is no known exploitation of CVE-2025-46821 in the wild and no public exploit code.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46821 and fix it if it is affected.

What it is: CVE-2025-46821 is a medium-severity vulnerability in Envoyproxy Envoy, published on 7 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-46821 in the wild and no public exploit code.

Affected packages and fixed versions:
- envoy (Bitnami): affected all versions; fixed in 1.31.8, 1.32.6, 1.33.3, 1.34.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46821/ (Markdown: https://insights.sbomify.com/CVE-2025-46821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46821
- OSV: https://osv.dev/vulnerability/CVE-2025-46821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46821/
Summaries are generated and may contain mistakes; the official description above is the record.
