# CVE-2025-46823: OpenMRS has Vulnerability in FHIR2 Module Privileges

> Unauthorized users can add or edit medical data due to missing privilege checks in the OpenMRS FHIR2 module.

- **Severity:** High 8.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 May 2025
- **Updated:** 29 May 2025
- **Also known as:** GHSA-g5vq-w8v2-4x9j

## What is CVE-2025-46823?

CVE-2025-46823 is a high-severity missing authorization vulnerability in openmrs-module-fhir2, published on 29 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

openmrs-module-fhir2 provides the FHIR REST API and related services for OpenMRS, an open medical records system. In versions of the FHIR2 module prior to 2.5.0, privileges were not always correctly checked, which means that unauthorized users may have been able to add or edit data they were not supposed to be able to. All implementers should update to FHIR2 2.5.0 or newer as soon as is feasible to receive a patch.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-46823?


## How do I fix CVE-2025-46823?

No fix has been published for CVE-2025-46823 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-46823 being exploited?

There is no known exploitation of CVE-2025-46823 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46823 and fix it if it is affected.

What it is: CVE-2025-46823 is a high-severity missing authorization vulnerability in openmrs-module-fhir2, published on 29 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-46823 in the wild and no public exploit code.

Affected product: openmrs-module-fhir2. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46823/ (Markdown: https://insights.sbomify.com/CVE-2025-46823/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46823
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46823
- OSV: https://osv.dev/vulnerability/CVE-2025-46823

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46823/
Summaries are generated and may contain mistakes; the official description above is the record.
