CVE-2025-46827 Graylog Allows Session Takeover via Insufficient HTML Sanitization
Attackers can steal session cookies via HTML injection in event definitions, requiring specific permissions and active inputs.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-46827?
CVE-2025-46827 is a high-severity cross-site scripting vulnerability in graylog2-server, published on 7 May 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Graylog is a free and open log management platform. Prior to versions 6.0.14, 6.1.10, and 6.2.0, it is possible to obtain user session cookies by submitting an HTML form as part of an Event Definition Remediation Step field. For this attack to succeed, the attacker needs a user account with permissions to create event definitions, while the user must have permissions to view alerts. Additionally, an active Input must be present on the Graylog server that is capable of receiving form data (e.g. a HTTP input, TCP raw or syslog etc). Versions 6.0.14, 6.1.10, and 6.2.0 fix the issue. No known workarounds are available, as long as the relatively rare prerequisites are met.
Weakness: CWE-79
Which versions are affected by CVE-2025-46827?
4 open source packages ship an affected version, including org.graylog2:graylog2-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.graylog2:graylog2-server Maven | All versions | 6.0.14 |
org.graylog2:graylog2-server Maven | All versions | 6.0.14 |
org.graylog2:graylog2-server Maven | From 6.1.0 | 6.1.10 |
org.graylog2:graylog2-server Maven | From 6.1.0 | 6.1.10 |
Products include Graylog Graylog.
How do I fix CVE-2025-46827?
Upgrade org.graylog2:graylog2-server to a fixed version for your release line: 6.0.14 or 6.1.10.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-46827 being exploited?
There is no known exploitation of CVE-2025-46827 in the wild and no public exploit code.
Other vulnerabilities in graylog2-server
- CVE-2021-37759 Information disclosure in n/a
- CVE-2021-37760 Information disclosure in n/a
- CVE-2026-1435 Incorrect management of session invalidation vulnerability in Graylog Web Interface
- CVE-2025-53106 Graylog vulnerable to privilege escalation through API tokens
- CVE-2024-24824 graylog2-server vulnerable to instantiation of arbitrary classes triggered by API request
Sources
Also known as GHSA-76vf-mpmx-777j.