# CVE-2025-46827: Graylog Allows Session Takeover via Insufficient HTML Sanitization

> Attackers can steal session cookies via HTML injection in event definitions, requiring specific permissions and active inputs.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 May 2025
- **Updated:** 7 May 2025
- **Also known as:** GHSA-76vf-mpmx-777j

## What is CVE-2025-46827?

CVE-2025-46827 is a high-severity cross-site scripting vulnerability in graylog2-server, published on 7 May 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Graylog is a free and open log management platform. Prior to versions 6.0.14, 6.1.10, and 6.2.0, it is possible to obtain user session cookies by submitting an HTML form as part of an Event Definition Remediation Step field. For this attack to succeed, the attacker needs a user account with permissions to create event definitions, while the user must have permissions to view alerts. Additionally, an active Input must be present on the Graylog server that is capable of receiving form data (e.g. a HTTP input, TCP raw or syslog etc). Versions 6.0.14, 6.1.10, and 6.2.0 fix the issue. No known workarounds are available, as long as the relatively rare prerequisites are met.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-46827?

4 open source packages ship an affected version, including org.graylog2:graylog2-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.graylog2:graylog2-server` | Maven | All versions | 6.0.14 |
| `org.graylog2:graylog2-server` | Maven | All versions | 6.0.14 |
| `org.graylog2:graylog2-server` | Maven | From 6.1.0 | 6.1.10 |
| `org.graylog2:graylog2-server` | Maven | From 6.1.0 | 6.1.10 |

Products: Graylog Graylog.

## How do I fix CVE-2025-46827?

Upgrade org.graylog2:graylog2-server to a fixed version for your release line: 6.0.14 or 6.1.10.

## Is CVE-2025-46827 being exploited?

There is no known exploitation of CVE-2025-46827 in the wild and no public exploit code.

## Other vulnerabilities in graylog2-server

- [CVE-2021-37759](https://insights.sbomify.com/CVE-2021-37759/): Information disclosure in n/a (critical 9.8)
- [CVE-2021-37760](https://insights.sbomify.com/CVE-2021-37760/): Information disclosure in n/a (critical 9.8)
- [CVE-2026-1435](https://insights.sbomify.com/CVE-2026-1435/): Incorrect management of session invalidation vulnerability in Graylog Web Interface (critical 9.3)
- [CVE-2025-53106](https://insights.sbomify.com/CVE-2025-53106/): Graylog vulnerable to privilege escalation through API tokens (high 8.8)
- [CVE-2024-24824](https://insights.sbomify.com/CVE-2024-24824/): graylog2-server vulnerable to instantiation of arbitrary classes triggered by API request (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46827 and fix it if it is affected.

What it is: CVE-2025-46827 is a high-severity cross-site scripting vulnerability in graylog2-server, published on 7 May 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-46827 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.graylog2:graylog2-server (Maven): affected all versions; fixed in 6.0.14
- org.graylog2:graylog2-server (Maven): affected all versions; fixed in 6.0.14
- org.graylog2:graylog2-server (Maven): affected from 6.1.0; fixed in 6.1.10
- org.graylog2:graylog2-server (Maven): affected from 6.1.0; fixed in 6.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46827/ (Markdown: https://insights.sbomify.com/CVE-2025-46827/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46827
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46827
- OSV: https://osv.dev/vulnerability/CVE-2025-46827

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46827/
Summaries are generated and may contain mistakes; the official description above is the record.
