CVE-2025-4691 Information disclosure in eaSYNC Booking – Hotels, Restaurants & Car Rentals

Medium 5.3 Published Updated

Unauthenticated attackers can view sensitive booking request details due to missing validation in the eaSYNC Booking WordPress plugin.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-4691?

CVE-2025-4691 is a medium-severity vulnerability in syntactics eaSYNC Booking – Hotels, Restaurants & Car Rentals, published on 31 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Free Booking Plugin for Hotels, Restaurants and Car Rentals – eaSYNC Booking plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.3.21 via the 'view_request_details' due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to view the details of any booking request. The vulnerability was partially patched in versions 1.3.18 and 1.3.21.

Weakness: CWE-639

Which versions are affected by CVE-2025-4691?

It affects 1 product.

Products include Syntacticsinc Easync.

How do I fix CVE-2025-4691?

No fix has been published for CVE-2025-4691 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-4691 being exploited?

There is no known exploitation of CVE-2025-4691 in the wild and no public exploit code.

Sources

Also known as GHSA-r4jv-p8qq-69jq.

Is CVE-2025-4691 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free