CVE-2025-4700 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

High 8.7 Published Updated

An attacker can trigger unintended content rendering leading to Cross-site Scripting in GitLab, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-4700?

CVE-2025-4700 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 23 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 15.10 before 18.0.5, 18.1 before 18.1.3, and 18.2 before 18.2.1 that, under specific circumstances, could have potentially allowed a successful attacker to trigger unintended content rendering leading to XSS.

Weakness: CWE-79

Which versions are affected by CVE-2025-4700?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.10.018.0.5, 18.1.3, 18.2.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-4700?

Upgrade gitlab to a fixed version for your release line: 18.0.5, 18.1.3 or 18.2.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-4700 being exploited?

There is no known exploitation of CVE-2025-4700 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-4700, GHSA-cgm9-25c8-vhvr, UBUNTU-CVE-2025-4700.

Is CVE-2025-4700 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free