{"answers":{"affected":"2 open source packages ship an affected version, including bootstrap-multiselect. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47204 exists.","fix":"Upgrade bootstrap-multiselect to 2.0.0 or later.","what":"CVE-2025-47204 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-47204 and fix it if it is affected.\n\nWhat it is: CVE-2025-47204 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47204 exists.\n\nAffected packages and fixed versions:\n- bootstrap-multiselect (npm): affected all versions; fixed in 2.0.0\n- bootstrap-multiselect (npm): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-47204/ (Markdown: https://insights.sbomify.com/CVE-2025-47204/index.md)","id":"CVE-2025-47204","markdown":"https://insights.sbomify.com/CVE-2025-47204/index.md","name":"CVE-2025-47204","record":{"aliases":["GHSA-gv5r-9gxr-v74w"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"JavaScript UI library","requires_auth":"none","summary":"Developers using this library's example code may expose applications to reflective XSS and CSRF attacks if they copy the vulnerable PHP script structure.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"bootstrap_multiselect","vendor":"davidstutz"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"An issue was discovered in post.php in bootstrap-multiselect (aka Bootstrap Multiselect) 1.1.2. A PHP script in the source code echoes arbitrary POST data. If a developer adopts this structure wholesale in a live application, it could create a Reflective Cross-Site Scripting (XSS) vulnerability exploitable through Cross-Site Request Forgery (CSRF).","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2025/CVE-2025-47204.yaml","stars":null,"title":"Bootstrap Multiselect \u003c= 1.1.2 - Cross-Site Scripting"}],"tier":"weaponised"},"has_fix":true,"headline":"Bootstrap Multiselect Vulnerable to CSRF and Reflective XSS via Arbitrary POST Data","id":"CVE-2025-47204","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"QTS, QuTS hero","id":"CVE-2025-47205"},"packages":[{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"bootstrap-multiselect","purl":null,"source":"GHSA-gv5r-9gxr-v74w"},{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"bootstrap-multiselect","purl":"pkg:npm/bootstrap-multiselect","source":"GHSA-gv5r-9gxr-v74w"}],"prev":{"headline":"Command injection in Dropbear SSH","id":"CVE-2025-47203"},"products":["n/a"],"published":"2025-05-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-14","vendors":["n/a"]},"summary":"Developers using this library's example code may expose applications to reflective XSS and CSRF attacks if they copy the vulnerable PHP script structure.","url":"https://insights.sbomify.com/CVE-2025-47204/"}