# CVE-2025-47204: Bootstrap Multiselect Vulnerable to CSRF and Reflective XSS via Arbitrary POST Data

> Developers using this library's example code may expose applications to reflective XSS and CSRF attacks if they copy the vulnerable PHP script structure.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 May 2025
- **Updated:** 14 May 2025
- **Also known as:** GHSA-gv5r-9gxr-v74w

## What is CVE-2025-47204?

CVE-2025-47204 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in post.php in bootstrap-multiselect (aka Bootstrap Multiselect) 1.1.2. A PHP script in the source code echoes arbitrary POST data. If a developer adopts this structure wholesale in a live application, it could create a Reflective Cross-Site Scripting (XSS) vulnerability exploitable through Cross-Site Request Forgery (CSRF).

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2025-47204?

2 open source packages ship an affected version, including bootstrap-multiselect. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bootstrap-multiselect` | npm | All versions | 2.0.0 |
| `bootstrap-multiselect` | npm | All versions | 2.0.0 |

Products: Davidstutz Bootstrap Multiselect.

## How do I fix CVE-2025-47204?

Upgrade bootstrap-multiselect to 2.0.0 or later.

## Is CVE-2025-47204 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47204 exists.

Public exploit code:

- Bootstrap Multiselect <= 1.1.2 - Cross-Site Scripting (nuclei): http/cves/2025/CVE-2025-47204.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47204 and fix it if it is affected.

What it is: CVE-2025-47204 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47204 exists.

Affected packages and fixed versions:
- bootstrap-multiselect (npm): affected all versions; fixed in 2.0.0
- bootstrap-multiselect (npm): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47204/ (Markdown: https://insights.sbomify.com/CVE-2025-47204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47204
- OSV: https://osv.dev/vulnerability/CVE-2025-47204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47204/
Summaries are generated and may contain mistakes; the official description above is the record.
