{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47256 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2025-47256 is a medium-severity memory corruption vulnerability in Libxmp, published on 6 May 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-47256 and fix it if it is affected.\n\nWhat it is: CVE-2025-47256 is a medium-severity memory corruption vulnerability in Libxmp, published on 6 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47256 exists.\n\nAffected product: Libxmp. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-47256/ (Markdown: https://insights.sbomify.com/CVE-2025-47256/index.md)","id":"CVE-2025-47256","markdown":"https://insights.sbomify.com/CVE-2025-47256/index.md","name":"CVE-2025-47256","record":{"aliases":["DEBIAN-CVE-2025-47256","GHSA-vg32-cm75-rjr5","UBUNTU-CVE-2025-47256","openSUSE-SU-2025:15081-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Libxmp library","requires_auth":"none","summary":"A stack-based buffer overflow in Libxmp allows attackers to execute arbitrary code or cause denial of service via a malformed Pha format tracker module.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":5.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-191","name":"Integer Underflow (Wrap or Wraparound)"}],"description":"Libxmp through 4.6.2 has a stack-based buffer overflow in depack_pha in loaders/prowizard/pha.c via a malformed Pha format tracker module in a .mod file.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2025-05-05","github_poc":1,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-05-05T12:55:07Z","kind":"github_poc","ref":"https://github.com/SexyShoelessGodofWar/CVE-2025-47256","stars":1,"title":"Stack overflow in LibXMP"}],"tier":"weaponised"},"has_fix":true,"headline":"Memory corruption in Libxmp","id":"CVE-2025-47256","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":1,"n_references":3,"next":{"headline":"Integer overflow in iputils","id":"CVE-2025-47268"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["4.6.3-1.1"],"introduced":["0"],"last_affected":[],"package":"libxmp","purl":"pkg:rpm/opensuse/libxmp\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15081-1"}],"prev":{"headline":"Privilege escalation in Checkmate","id":"CVE-2025-47245"},"products":["Libxmp"],"published":"2025-05-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-06","vendors":["Libxmp"]},"summary":"A stack-based buffer overflow in Libxmp allows attackers to execute arbitrary code or cause denial of service via a malformed Pha format tracker module.","url":"https://insights.sbomify.com/CVE-2025-47256/"}